Bug#886068: gtk-theme-config: Depends on gconf

Jeremy Bicha jbicha at debian.org
Tue Jan 2 01:50:36 UTC 2018


Source: gtk-theme-config
Version: 1.2.2-1
Severity: important
User: pkg-gnome-maintainers at lists.alioth.debian.org
Usertags: oldlibs gconf
Tags: sid buster

Your package depends or build-depends on gconf, but gconf will be
removed from Debian soon.

gconf's last release was about 5 years ago. It has been replaced by
gsettings (provided in Debian by source glib2.0 )

This should be pretty simple to fix since I don't think any desktop in
Debian uses gconf any more so you should be able to just drop the gconf
code.

References
----------
https://developer.gnome.org/gio/stable/ch34.html
https://developer.gnome.org/gio/stable/GSettings.html

On behalf of the Debian GNOME team,
Jeremy Bicha



More information about the xubuntu-devel mailing list