GTK3 Indicators

Richard Elkins richard.elkins at
Sat Dec 14 16:07:45 UTC 2013

Yes, I followed all instructions in the link 'to the letter' .....


  * sudo apt-get update && sudo apt-get upgrade
  * sudo add-apt-repository ppa:shimmerproject/daily
  * sudo add-apt-repository ppa:noskcaj/indicator-gtk3
  * sudo add-apt-repository ppa:xubuntu-dev/xfce-4.12
  * sudo apt-get update
  * sudo apt-get dist-upgrade
  * sudo apt-get install indicator-power indicator-bluetooth indicator-datetime indicator-keyboard indicator-printers indicator-sound indicator-sync indicator-messages
  * sudo apt-get purge indicator-sound-gtk2 indicator-application-gtk2

Operationally, I tried both:
1 - Logout and login (installed indicators should appear after the
desktop processes for current user are started)
2 - sudo reboot

Just for fun:

  * Enabled Trusty "proposed" repository.
  * sudo apt-get update
  * sudo apt-get dist-upgrade
  * sudo reboot
  * sudo apt-get update
  * sudo apt-get dist-upgrade
  * Tried above operational tests again.

No dice.  Which of the PPA owners would I contact?  I need instructions
on what data to collect.  No problem for me to do another ground-up,
patching, etc. on the machine.

A caveat that may or may not make a difference (probably not) .....

Due to a current shortage of hardware here at home to test on (unusual
for me), I am testing Trusty with another Intel D2550 CedarView
motherboard (same as the last one).  Recall that Intel has abandoned
Linux driver support for CedarView (Atom 2500/2550/2600/2700/2800) and
GMA3600/3650 aka PowerVR SGX545.  This probably has no bearing on the
issue at hand and, in general, Xubuntu installation/reboot does a very
good job of kernel module "approximation" (gma500_gfx instead of i915)
and X video driver selection (modesetting).  In fact, I'd advise anyone
having a CedarView netbook, laptop, or motherboard to use the latest
Xubuntu if their interest is to operate a Linux or Unix OS.  But, it
does make me think twice about reporting bugs with this rig.


On 12/14/2013 01:28 AM, Elfy wrote:
> On 13/12/13 19:15, Richard Elkins wrote:
>> Elfy,
>> Followed instructions.  The sound indicator did not show up on Panel 0
>> in the right-hand corner.  The work-around
>> ("INDICATOR_ALLOW_NO_WATCHERS=yes" in /etc/environment and reboot) had
>> no effect.  Be patient and wait for the migration to complete?
>> The psensor showed up and is useful.  Date/Time is still there.
>> Different subject: Anyone have an idea why "Extras" is still MIA (404)?
>> The work-around is easy (use Saucy Extras in place of Trusty Extras).
>> Again, wait for future instructions?
>> Richard
> Did the sound-indicator appear yet - assuming a reboot in the
> meantime. I've personally had no issues with it - I was using the
> previous instructions (saucy) and had it constantly. Lost it on the
> sudo make uninstalls - which was good - the one time I was expecting
> to lose it, then it reappeared after following the new instructions.
> You did I assume install it?
> As far as Extras goes - I rarely bother enabling it for at least the
> first few months. Though there's nothing in there I particularly need
> or want.
> Elfy

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the xubuntu-devel mailing list