[Bug 162448] [NEW] Querying Thunar /proc directory causes hang

Launchpad Bug Tracker 162448 at bugs.launchpad.net
Sat Mar 29 15:46:46 UTC 2008

You have been subscribed to a public bug:

This is on a Xubuntu 7.04 machine functioning as an LTSP server.

#uname -a
Linux halorentz-acss 2.6.20-16-server #2 SMP Sun Sep 23 19:57:25 UTC 2007 i686 GNU/Linux

User authentication is done via an LDAP server.  The /home directory is
mounted over NFS from another server and users can mount their USB flash
drives from the LTSP clients using LTSPFS.

On rare occasions I will find that running 'ps' will hang and the
terminal becomes non-responsive. If I run 'ps awx' I get a list of
processes which stops just before the "offending" process. If I then
list the contents of /proc I can find the offending process ID (the next
process numerically) and find out who owns it. However running 'cat' on
the process's /proc cmdline file will also hang. (e.g. 'cat
/proc/821/cmdline' hangs and the terminal becomes non-responsive). I can
run top, but if I hit "c" to list the command line details then top
hangs as well.

In the current case the offending process is "Thunar". I believe it was
in the previous cases as well, but I don't recall for sure. Looking via
top at the user's processes I can see that they have logged out, but
there are a couple processes left:

  821 xxxxxxx  15   0 75608  13m 9356 D    0  0.2   0:01.01 Thunar
  824 xxxxxxx  15   0  2680 1212  884 S    0  0.0   0:00.32 gam_server
 1144 xxxxxxx  20   0 77848 1056  384 S    0  0.0   0:00.10 ltspfs
 1750 xxxxxxx  25   0  1716  524  444 S    0  0.0   0:00.01 soffice
 1766 xxxxxxx  15   0  203m  81m  58m D    0  1.0   0:14.87 soffice.bin
 7162 xxxxxxx  15   0     0    0    0 Z    0  0.0   0:00.63 Thunar <defunct>
 8770 xxxxxxx  15   0     0    0    0 Z    0  0.0   0:00.76 Thunar <defunct>

In this case it seems to be process 821 that is causing the problem.

I don't know how to reproduce this effect.

Killing the process returns everything to normal, but it seems to take
quite a while to get it to quit. I tried several times before
succeeding. Running 'pkill -9 -u xxxxxxx' seemed to do the trick.

** Affects: thunar (Ubuntu)
     Importance: Undecided
         Status: New

Querying Thunar /proc directory causes hang
You received this bug notification because you are a member of Xubuntu Team, which is subscribed to thunar in ubuntu.

More information about the xubuntu-devel mailing list