[Bug 207976] [NEW] gnome xfce interoperation --> X cannot load (hardy beta)

Phil Koh undercling9-99 at yahoo.com.au
Thu Mar 27 21:30:49 UTC 2008

Public bug reported:

Binary package hint: xubuntu-desktop

I installed ubuntu hardy beta (old HP P3 500MHZ, on 26-03-2008).

Performed updates and was pretty ok (except screen resolution setting
was not kept between boots however and actually autodetect was too high
it caused fragmentation of image).

Then I installed xubuntu-desktop and vlc.

X would refuse to load.  Trying six times then giving the 2min warning
on some occassions, on other occassions, not leaving the loading/wait
mouse cursor icon.

=========== What I tried=============
I tried loading a Gutsy live CD and copied the xorg.conf from the live CD to replace the HD /etc/X11.
Still had X errors.
Hardy (bulletproofX?) overwrote the new xorg.conf so I recopied it and made it read only (chmod 444).
Still X errors.

Then I gave up fighting bulletproofX...  (it's probably so bullet proof
it's hard to override).

Installed Xubuntu instead (do without the ubuntu-desktop)

At bare minimum: if xubuntu and ubuntu do handle the loading of X
settings in a way that conflicts, perhaps we would want to put a warning
on the xubuntu-desktop and the ubuntu-desktop descriptions in the

** Affects: xubuntu-meta (Ubuntu)
     Importance: Undecided
         Status: New

gnome xfce interoperation --> X cannot load (hardy beta)
You received this bug notification because you are a member of Xubuntu
Team, which is subscribed to xubuntu-meta in ubuntu.

More information about the xubuntu-devel mailing list