Fwd: libX11/XCB problems in Hardy

Cody A.W. Somerville cody-somerville at ubuntu.com
Mon Jun 23 13:35:43 BST 2008


If you spend anytime in #xubuntu-devel (or if you've experienced this issue
yourself), you'll knew it isn't much fun. Luckily, I'm happy to report that
I think I may have found a fix (at least a fix to avoid the problem). For
those of you experiencing the freezing at the login, edit
/etc/xdg/xfce4/xinitrc so that the dbus-launch stuff occurs before the
screensaver stuff. This should hopefully result in it not hanging on login
for you anymore. If it does, let me know and then try adding a sleep 1
statement inbetween dbus-launch stuff and screensaver stuff and see if you
can still reproduce it. Be sure to attach your modified xinitirc file when
you send me your success or failures.

Cheers,

Your fearless leader Cody ;]

---------- Forwarded message ----------
From: Bryce Harrington <bryce at canonical.com>
Date: Fri, Jun 20, 2008 at 11:33 PM
Subject: libX11/XCB problems in Hardy
To: ubuntu-devel at lists.ubuntu.com


A couple fairly subtle but serious issues have come to light in Hardy
relating to XCB-enablement in libX11, and I wanted to send this note
to notify of a pending change we'll push out once we have a bit more
verification.


185311  locking assertion failure, xorg/libsdl (13 dupes)
       Particularly afflicting OpenOffice.org users


232364  dbus-launch hangs at session start waiting on socket output in
libxcb
       Particularly afflicting Xubuntu users


Both issues have seemingly been traced to be related to and/or due to
the enablement of XCB in libx11.  While we're not 100% certain libxcb is
at fault here, in contacting XCB upstream it seems that locking issues
are a known issue with the current version and re-architecting work is
underway to resolve them.

In the interim, for Hardy I'm considering that we should revert XCB in
libx11.  I've prepared libx11 debs with XCB disabled for testing
purposes at the above bug id's.  If we can get this verified as
resolving the issue (and causing no other notable regression), we can
decide on putting an SRU through on it.

I'm guessing that the new libxcb will not be appropriate for a Hardy
SRU, but we should certainly include it for testing in Intrepid.

Thanks go to Calc and Cody for their frontline work on the respective
issues.

Bryce

----- Forwarded message from Barton C Massey <bart at cs.pdx.edu> -----

Date: Fri, 20 Jun 2008 18:06:23 -0700
From: Barton C Massey <bart at cs.pdx.edu>
To: Bryce Harrington <bryce at canonical.com>
cc: cody-somerville at ubuntu.com, jamey at cs.pdx.edu, tripletj at cs.pdx.edu
Subject: Re: (X)Ubuntu hang with XCB / dbus-launch
X-Spam-Status: No, score=0.5 required=5.0 tests=AWL,EMPTY_MESSAGE
autolearn=no
       version=3.2.4

Hi Bryce!  Going well.  I've Cc-ed Jamey and Josh, who
are the canonical designees for this stuff.  Jamey is biking
for a week in the San Juans, and thus completely
uncontactable.  I called Josh and we had a long and
informative conversation about the state of things.

This is almost surely a bug in libXCB or Xlib: calling
XOpenDisplay() arguably should never hang you.

Jamey and Josh are finishing up "connection handoff" code
that completely re-architectes the Xlib / XCB interaction,
and may solve this problem and a bunch of others.  They're
close to finishing cleaning up this code and shipping it as
the next release of Xlib/XCB.

In the meantime, Josh will look at this bug and let you know
if he sees anything obvious; also, he may ask you to ship
experimental bits to some users with the problem and see if
things get all better for them.

Thanks much for the note.

       Bart

In message <20080620215012.GV9928 at bryceharrington.org> you wrote:
> We've got a bit of an XCB-related deadlocking problem I'm trying to help
> Cody with.  Cody is the lead maintainer of Xubuntu, and this particular
> bug is afflicting a huge proportion of the Xubuntu users.  I'm hoping
> you could either give us some pointers on debugging this, or introduce
> us to someone who can help figure it out?
>
> The issue is that during dbus-launch start up, there is a hang following
> the select() call in _xcb_in_read_block().  I've filed a bug in fdo
> bugzilla here:
>
>   https://bugs.freedesktop.org/show_bug.cgi?id=16420
>
> We're not certain that it's a libxcb bug, or an underlying bug that
> libxcb just exposes in this particular environment.  Do you have any
> advice on what we could do to chase this down (and/or work around it)?

----- End forwarded message -----

--
ubuntu-devel mailing list
ubuntu-devel at lists.ubuntu.com
Modify settings or unsubscribe at:
https://lists.ubuntu.com/mailman/listinfo/ubuntu-devel



-- 
Cody A.W. Somerville
Software Engineer
Red Cow Marketing & Technologies, Inc.
Office: 506-458-1290
Toll Free: 1-877-733-2699
Fax: 506-453-9112
Cell: 506-449-5899
Email: cody at redcow.ca
http://www.redcow.ca
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/xubuntu-devel/attachments/20080623/ce916e1c/attachment.htm 


More information about the xubuntu-devel mailing list