[Bug 224830] [NEW] [Xubuntu 8.04] Problem with mounting partition, external usb drives and permissions

Srik maxpower at email.it
Wed Apr 30 17:21:45 UTC 2008

Public bug reported:

I'm using an xubuntu 8.04 just installed.
I don't know if it's a wrong setting in user permission (or something similar) that generates all these problems or if they are different bugs (surely there's a problem with PolicyKit configuration!). However these are the problems:

- Xubuntu doesn't put in the "places" menu the link to the other partion
(it's a fat32 part. windows inside).

- Using fdisk -l and the mount command it's possible to mount it.

- So i tried "gparted" and it gave this error:
  "Errore nel montaggio di "Disco 22G".. (my translation: error in mounting "name of the disk")
   org.freedesktop.hal.storage.mount-fixed auth_admin_keep_always <-- (action, result)."

- Following the instructions that are in the following link
http://hal.freedesktop.org/docs/PolicyKit/PolicyKit.conf.5.html ,i added
these lines to my /etc/PolicyKit/policyKit.conf:

<match action="org.freedesktop.hal.storage.mount-fixed">
  <match user="root">
    <return result="yes"/>
  <match user="myuser">
    <return result="yes"/>

- Then restarting gparted the error disappeared and it automatically
mounted the fat 32 partition (with the opening of the thunar window) but
it continues to not appear in the "Places" menu. (the partition has been
mounted in /media/disk )

- Then i tried to put and usb pen and nothing happened. It was
impossible to mount it with gparted (the option wasn't active) and there
was nothing (related to the usb pen) in the /media/ or /mnt/ folders.

- So i checked privileges of my current user following this path in the
menu "applications -> system -> users settings (in italian is "groups
and users"). The auto mount for the usb external drives was active for
the current user (the user i use to log-in at the start-up) but not for
the root user (nothing was active!). So i tried to activate the auto-
mount for the root user, then i plugged my usb-pen and it has been
mounted with the appearing of an icon on the desktop.  (i want to note
that i'm not logged as root)

- Using the "mount devices" element that i added to the lower bar:
 it doesn't give the option to mount the fat 32 partition because it isn't in the list but it appears (in the list) when i mount it manually with the mount command. So when i click on it in the list to unmount it, it appears an error windows with this messagge: " An error occurred. The device should not be removed! ".In the other hand, when the partition has been mounted by gparted automatically, the mount devices element says "The device "/media/disk" should be removable safely now."; but it has been just unmounted (it's not a removable media, it's just a partition). However it unmount it correctly.

** Affects: ubuntu
     Importance: Undecided
         Status: New

[Xubuntu 8.04] Problem with mounting partition, external usb drives and permissions
You received this bug notification because you are a member of Xubuntu
Team, which is a direct subscriber.

More information about the xubuntu-devel mailing list