Problem with adding samba printer in Herd 5

Jelle de Jong jelledejong at
Sun Mar 4 08:40:13 UTC 2007

Foxy wrote:
> Due to some crash of my laptop I decide to ditch Dapper and switch to 
> Feisty. This is the first time I decided to install Xubuntu. Before I 
> usually used Ubuntu with XFCE.
> The installation was fine but I ran into trouble trying to add Windows 
> samba printer. I used Settings/Printing. The programme properly 
> identified my shared printer by clicking on it did not add the printer's 
> address in the upper window (smb:// ...).
> I tried to do it manually by enabling localhost:631 and using cups 
> interface, but still I cannot do it. I think I have the address wrong 
> for some reason. I tried to run smbtree:
>> ~$ smbtree 
>> Password: 
>>         \\NECAPTOP                      necaptop server (Samba, Ubuntu)
>>                 \\NECAPTOP\IPC$                 IPC Service (necaptop server (Samba, Ubuntu))
>>                 \\NECAPTOP\etc_nec        
>>                 \\NECAPTOP\sveta          
>>                 \\NECAPTOP\sasha          
>>                 \\NECAPTOP\alex           
>>                 \\NECAPTOP\print$               Printer Drivers
>>         \\AC-PC                         Al's Uber PC
>>                 \\AC-PC\diskl          
>>                 \\AC-PC\L$              Default share
>>                 \\AC-PC\C$              Default share
>>                 \\AC-PC\H$              Default share
>>                 \\AC-PC\ADMIN$          Remote Admin
>>                 \\AC-PC\dx3800          EPSON Stylus DX3800 Series
>>                 \\AC-PC\diskd          
>>                 \\AC-PC\print$          Printer Drivers
>>                 \\AC-PC\SharedDocs     
>>                 \\AC-PC\D$              Default share
>>                 \\AC-PC\IPC$            Remote IPC
>>                 \\AC-PC\diskh          
> So I put smb://WORKGROUP/AK-PC/dx3800, but CUPS shows
>> "Unable to connect to CIFS host, will retry in 60 seconds..."

Maybe the problem is somewhere else i don't know. But can you mount a
smb share and use it normally. So we can be sure it is a printer issue?

Best regards,


More information about the xubuntu-devel mailing list