Which libgtkhtml library to use for xhelp?

Radomir Dopieralski xubuntu at sheep.art.pl
Sat Jul 28 20:51:18 UTC 2007


Sat, Jul 28, 2007 at 10:10:05PM +0200: 
> Hi,
> 
> I would like to know which version of libgtkhtm to use for Xhelp, the
> Xubuntu Documentation Browser:
> 
> gt[xhelp]$ apt-cache search libgtkhtml
> libgtkhtml2-0 - HTML rendering/editing library - runtime files. (for GNOME2)
> libgtkhtml2-dev - HTML rendering/editing library - development files.
> for (GNOME2)
> libgtkhtml3.14-19 - HTML rendering/editing library - runtime files
> libgtkhtml3.14-dbg - HTML rendering/editing library - debug files
> libgtkhtml3.14-dev - HTML rendering/editing library - development files
> libgtkhtml2-ruby - GtkHTML bindings for the Ruby language
> libgtkhtml3.8-15 - HTML rendering/editing library - runtime files
> libgtkhtml3.8-dbg - HTML rendering/editing library - debug files
> libgtkhtml3.8-dev - HTML rendering/editing library - development files
> 
> Shall I use the 2, the 3.14 or the 3.8-15 ??

As far as I know, gtkhtml2 and 3 are completely different forks of the
gtkhtml library. Gtkhtml2 has pretty well support of html and css
(although the css support is still very partial). I think it's used by
the GNOME's Yelp help browser.

The gtkhtml3 is, I think, developed mainly for Evolution, and it has well
developed support for editing the html.

There was also a project for gtkhtml4, which was supposed to merge the
features of 2 and 3, but I don't know what is the state of it.


-- 
Radomir `The Sheep' Dopieralski 
()  ascii ribbon campaign - against html e-mail 
/\  <www.asciiribbon.org> - against proprietary attachments




More information about the xubuntu-devel mailing list