[ubuntu/xenial-security] python-psutil 3.4.2-1ubuntu0.1 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Thu Nov 28 12:40:32 UTC 2019


python-psutil (3.4.2-1ubuntu0.1) xenial-security; urgency=medium

  * SECURITY UPDATE: double-free via refcount mishandling
    - debian/patches/CVE-2019-18874-1.patch: use Py_CLEAR instead of
      Py_DECREF in psutil/_psutil_linux.c.
    - debian/patches/CVE-2019-18874-2.patch: use Py_CLEAR instead of
      Py_DECREF in psutil/_psutil_posix.c.
    - CVE-2019-18874

Date: 2019-11-22 16:00:21.609661+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/python-psutil/3.4.2-1ubuntu0.1
-------------- next part --------------
Sorry, changesfile not available.


More information about the Xenial-changes mailing list