[ubuntu/xenial-security] libgd2 2.1.1-4ubuntu0.16.04.11 (Accepted)

Marc Deslauriers marc.deslauriers at canonical.com
Thu Feb 28 14:02:59 UTC 2019


libgd2 (2.1.1-4ubuntu0.16.04.11) xenial-security; urgency=medium

  * SECURITY UPDATE: buffer overflow in gdImageColorMatch
    - debian/patches/CVE-2019-6977.patch: use gdMaxColors in
      src/gd_color_match.c.
    - CVE-2019-6977
  * SECURITY UPDATE: double-free in gdImage*Ptr() functions
    - debian/patches/CVE-2019-6978.patch: properly handle failure in
      src/gd_gif_out.c, src/gd_jpeg.c, src/gd_wbmp.c, add test to
      tests/jpeg/CMakeLists.txt, tests/jpeg/jpeg_ptr_double_free.c.
    - CVE-2019-6978

Date: 2019-02-27 20:14:15.345833+00:00
Changed-By: Marc Deslauriers <marc.deslauriers at canonical.com>
https://launchpad.net/ubuntu/+source/libgd2/2.1.1-4ubuntu0.16.04.11
-------------- next part --------------
Sorry, changesfile not available.


More information about the Xenial-changes mailing list