[Bug 700167] [NEW] [pull-lp-source] Crash with non-existing package

Artur Rona ari-tczew at ubuntu.com
Sat Jan 8 00:00:46 UTC 2011


Public bug reported:

Binary package hint: ubuntu-dev-tools

$ pull-lp-source rhythbox maverick-updates
Traceback (most recent call last):
  File "/usr/bin/pull-lp-source", line 109, in <module>
    main()
  File "/usr/bin/pull-lp-source", line 83, in main
    Logger.error(error)
  File "/usr/lib/python2.7/dist-packages/ubuntutools/logger.py", line 45, in error
    print >> cls.stderr, "%s: Error: %s" % (cls.script_name, message % args)
TypeError: unsupported operand type(s) for %: 'PackageNotFoundException' and 'tuple'


$ apt-cache policy ubuntu-dev-tools
ubuntu-dev-tools:
  Zainstalowana: 0.109~daily+bzr945~natty1
  Kandydująca:   0.109~daily+bzr945~natty1
  Tabela wersji:
 *** 0.109~daily+bzr945~natty1 0
        100 /var/lib/dpkg/status
     0.108 0
        500 http://pl.archive.ubuntu.com/ubuntu/ natty/universe i386 Packages

** Affects: ubuntu-dev-tools (Ubuntu)
     Importance: Undecided
         Status: New

-- 
You received this bug notification because you are a member of MOTU,
which is subscribed to ubuntu-dev-tools in ubuntu.
https://bugs.launchpad.net/bugs/700167

Title:
  [pull-lp-source] Crash with non-existing package




More information about the universe-bugs mailing list