[Bug 611075] [NEW] ubuntu-dev-tools: requestsync doesn't support STARTTLS

Michael Bienia michael at bienia.de
Wed Jul 28 21:57:44 UTC 2010


Public bug reported:

Imported from Debian bug 590732:

Package: ubuntu-dev-tools
Version: 0.100
Severity: normal


It seems requestsync doesn't support using STARTTLS. Attempting to relay a sync
request though a server that requires TLS before authentication gives me the
error (e-mail address obscured):

Connecting to smtp.unchartedbackwaters.co.uk:587 ...
Traceback (most recent call last):
  File "/usr/bin/requestsync", line 242, in <module>
    mailBug(srcpkg, subscribe, status, title, report, options.keyid)
  File "/usr/lib/pymodules/python2.6/ubuntutools/requestsync/mail.py", line 226, in mailBug
    s.sendmail(myemailaddr, to, mail.encode('utf-8'))
  File "/usr/lib/python2.6/smtplib.py", line 698, in sendmail
    raise SMTPSenderRefused(code, resp, from_addr)
smtplib.SMTPSenderRefused: (530, '5.7.0 Must issue a STARTTLS command first', '#######@###################.##.##')

I note that reportbug has no problems with STARTTLS, but requires that an option
be set in .reportbugrc.

Francis

-- System Information:
Debian Release: squeeze/sid
  APT prefers testing
  APT policy: (500, 'testing'), (50, 'unstable')
Architecture: amd64 (x86_64)

Kernel: Linux 2.6.34.1 (SMP w/2 CPU cores)
Locale: LANG=en_GB.UTF-8, LC_CTYPE=en_GB.UTF-8 (charmap=UTF-8)
Shell: /bin/sh linked to /bin/dash

Versions of packages ubuntu-dev-tools depends on:
ii  binutils                      2.20.1-12  The GNU assembler, linker and bina
ii  dctrl-tools                   2.14       Command-line tools to process Debi
ii  devscripts                    2.10.65.1  scripts to make the life of a Debi
ii  diffstat                      1.47-1     produces graph of changes introduc
ii  dpkg-dev                      1.15.7.2   Debian package development tools
ii  lsb-release                   3.2-23.1   Linux Standard Base version report
ii  python                        2.6.5-5    An interactive high-level object-o
ii  python-apt                    0.7.96.1   Python interface to libapt-pkg
ii  python-debian                 0.1.16     Python modules to work with Debian
ii  python-launchpadlib           1.6.2-1    Launchpad web services client libr
ii  python-lazr.restfulclient     0.9.20-1   client for lazr.restful-based web 
ii  python-support                1.0.9      automated rebuilding support for P
ii  sudo                          1.7.2p7-1  Provide limited super user privile

Versions of packages ubuntu-dev-tools recommends:
ii  bzr                           2.1.2-1    easy to use distributed version co
ii  ca-certificates               20090814   Common CA certificates
ii  debootstrap                   1.0.23     Bootstrap a basic Debian system
ii  genisoimage                   9:1.1.10-1 Creates ISO-9660 CD-ROM filesystem
ii  libapt-pkg-perl               0.1.24     Perl interface to libapt-pkg
ii  libwww-perl                   5.836-1    Perl HTTP/WWW client/server librar
ii  pbuilder                      0.199      personal package builder for Debia
ii  perl-modules                  5.10.1-13  Core Perl modules
ii  reportbug                     4.12.4     reports bugs in the Debian distrib

Versions of packages ubuntu-dev-tools suggests:
pn  qemu-kvm-extras-static        <none>     (no description available)

-- no debconf information

** Affects: ubuntu-dev-tools (Ubuntu)
     Importance: Undecided
         Status: New

** Affects: ubuntu-dev-tools (Debian)
     Importance: Undecided
         Status: New

** Bug watch added: Debian Bug tracker #590732
   http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=590732

** Changed in: ubuntu-dev-tools (Debian)
 Remote watch: None => Debian Bug tracker #590732

-- 
ubuntu-dev-tools: requestsync doesn't support STARTTLS
https://bugs.launchpad.net/bugs/611075
You received this bug notification because you are a member of MOTU,
which is subscribed to ubuntu-dev-tools in ubuntu.




More information about the universe-bugs mailing list