[Bug 524203] [NEW] Feature Freeze exception for Parrot 2.0 sync

Allison Randal allison at parrot.org
Fri Feb 19 02:27:17 UTC 2010


Public bug reported:

Binary package hint: parrot

Parrot 2.0 was released on January 19th, and I finished the Debian
packaging for it on Feb 7th. I was hoping one of our Debian sponsors
would be able to upload it in time to do a sync to Ubuntu before the
FeatureFreeze, but they didn't have time (they're also Ubuntu devs, so I
imagine they were busy preparing for the FeatureFreeze). I ran into
Matthias Klose at the Python Language Summit today and he suggested
submitting a freeze exception now so the packages can (hopefully) be
synced as soon as they're uploaded into Debian unstable.

Aside from substantial performance improvements and general feature
enhancements, the biggest change in 2.0 from 1.4 (the previous stable
release which went into Karmic and is currently in Lucid) is the
addition of a new suite of compiler tools which will be needed in
building packages for the Parrot implementations of Python, Perl, Ruby,
etc. Getting the added parrot tools into Lucid will be especially
important since it is an LTS release. Currently, no packages depend on
the Parrot packages, so the impact should be minimal.

The buildlogs for successful lucid builds are available for i386 and
amd64 in my PPA:

https://launchpad.net/~allison/+archive/ppa/+build/1488884
https://launchpad.net/~allison/+archive/ppa/+build/1488883

And the Debian source packages for Parrot 2.0 are available here:

http://pub.lohutok.net/debian/

** Affects: parrot (Ubuntu)
     Importance: Undecided
         Status: New

-- 
Feature Freeze exception for Parrot 2.0 sync
https://bugs.launchpad.net/bugs/524203
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

-- 
ubuntu-bugs mailing list
ubuntu-bugs at lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs




More information about the universe-bugs mailing list