[Bug 517151] [NEW] not abe to make linux-source-2.6.31

Newbie jyothi.birajdar at gmail.com
Thu Feb 4 17:13:36 UTC 2010

Public bug reported:

Hi all,

   I'm to trying the linux-source-2.6.31 and facing problems doing this
I copied and pasted the console message what I get here:
CC      ubuntu/apparmor/lsm.o
  CC      ubuntu/apparmor/resource.o
  CC      ubuntu/apparmor/sid.o
  CC      ubuntu/apparmor/file.o
  CC      ubuntu/apparmor/net.o
  LD      ubuntu/apparmor/apparmor.o
  LD      ubuntu/apparmor/built-in.o
  CC      ubuntu/aufs/module.o
  CC      ubuntu/aufs/sbinfo.o
In file included from ubuntu/aufs/aufs.h:28,
                 from ubuntu/aufs/sbinfo.c:23:
ubuntu/aufs/debug.h: In function âau_debugâ:
ubuntu/aufs/debug.h:46: error: implicit declaration of function âsmp_mbâ
ubuntu/aufs/debug.h: At top level:
ubuntu/aufs/debug.h:146: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âau_debug_initâ
ubuntu/aufs/debug.h:238: error: expected â=â, â,â, â;â, âasmâ or â__attribute__â before âau_sysrq_initâ
make[3]: *** [ubuntu/aufs/sbinfo.o] Error 1
make[2]: *** [ubuntu/aufs] Error 2
make[1]: *** [ubuntu] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.31'
make: *** [debian/stamp/build/kernel] Error 2
the problem is in aufs module ....Please help with me with this asap

Thanks in advance

** Affects: aufs (Ubuntu)
     Importance: Undecided
         Status: New

not abe to make linux-source-2.6.31
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

ubuntu-bugs mailing list
ubuntu-bugs at lists.ubuntu.com

More information about the universe-bugs mailing list