[Bug 59386] using /dev/ttyUSB0 in gnome-ppp

ozonehole taibei at yahoo.com
Thu Mar 22 00:46:30 UTC 2007

Public bug reported:

Binary package hint: gnome-ppp

I recently succeeded in getting Ubuntu to work with an external serial
modem attached to my computer through the USB port. However, this was
difficult to configure and I'm sure a newbie couldn't do it. Yet a
simple change to gnome-ppp would have made it easy. More details

First, to describe my hardware: a notebook computer (IBM ThinkPad X31),
which has no serial ports but has USB ports. I purchased a special cable
which has a built-in adaptor, so that the USB port can be physically
connected to an external serial modem.

The problem is this: the character device required for this set-up to
work is /dev/ttyUSB0. Fortunately, this device does exist in Ubuntu, as
you can see:

bob at x31:/> ls -l /dev/ttyUSB0 
crw-rw---- 1 root dialout 188, 0 2006-09-07 09:36 /dev/ttyUSB0

The only trouble is that gnome-ppp does not recognize /dev/ttyUSB0. When
you try to configure it, you are only offered these choices:


There is in fact no /dev/modem - it is a symbolic link. For me to make
my hardware work, I had to create a symbolic link:

   ln -s /dev/ttyUSB0 /dev/modem

After this, I could configure gnome-ppp to access my modem using
/dev/modem. So it worked - until I rebooted. Thanks to udev, every time
I rebooted my /dev/modem would disappear and I had to create it manually
again. To solve this problem, I created a start-up script (which I named
modem.sh) with this content:

   #! /bin/sh 
   ln -s /dev/ttyUSB0 /dev/modem

I placed the script in /etc/init.d and ran this command:

   update-rc.d modem.sh defaults

Now I am able to use my modem with gnome-ppp, so my problem is solved.
The only real issue is that all of the above would be nearly impossible
for a Linux newbie to figure out. It occurs to me that this complexity
would be rendered unnecessary if gnome-ppp simply offered /dev/ttyUSB0
as one of its choices. It is my suggestion that this should be done for
the next release.

best regards,

** Affects: gnome-ppp (Ubuntu)
     Importance: Medium
     Assignee: MOTU
         Status: Confirmed

using /dev/ttyUSB0 in gnome-ppp

More information about the universe-bugs mailing list