[Bug 65388] Re: [UNMETDEPS] illuminator has unmet dependencies

mlind matti.lindell at gmail.com
Thu Jan 18 23:12:27 UTC 2007


I'm not sure why petsc upstream is breaking API's this way when version
number indicates a stable maintenance release (2.3.2). Change is
documented on http://www-unix.mcs.anl.gov/petsc/petsc-
as/documentation/changes/232.html

I'm attaching a debdiff with small patch that should work with petsc >=
2.3.0 and is backwards-compatible, it's untested though and I'm not sure
if it even works. There's something weird going on with petsc
librairies, tsview --help just gives me bunch of petsc errors..

Changed PetscRandomCreate is documented in http://www-
unix.mcs.anl.gov/petsc/petsc-as/snapshots/petsc-
current/docs/manualpages/Sys/PetscRandomCreate.html#PetscRandomCreate.
If anyone with more brain wants to poke this around.


** Attachment added: "patch to possibly fix the issue"
   http://librarian.launchpad.net/5787140/debdiff

-- 
[UNMETDEPS] illuminator has unmet dependencies
https://launchpad.net/bugs/65388




More information about the universe-bugs mailing list