[Bug 102212] Re: [needs-packaging] Metasploit Framework 3.0

Kristian Hermansen kristian.hermansen at gmail.com
Wed Aug 15 15:31:45 UTC 2007


On 8/15/07, Justin M. Wray <wray.justin.ubuntu at gmail.com> wrote:
> > E: metasploit: wrong-path-for-ruby ./usr/share/metasploit/external
> /ruby-pcapx/examples/tcpdump.rb #!/usr/local/bin/ruby
>
> Your script does _NOT_ seem to fix this error.  However, I do not get
> that output with or without your patch.

It should!  The clean_ruby_paths function should change three files
which have this issue.  Does it not?  I basically just do a sed on the
files and replace with (/usr/bin/env ruby).  You could fix my script,
if it is broken, but  don't think it is!  Or you could write another
script/patch which does this.  Or manually.  Then we can get it
packaged and uploaded for Gutsy.  We only have two weeks though.  So,
let's hustle :-)
-- 
Kristian Erik Hermansen

-- 
[needs-packaging] Metasploit Framework 3.0
https://bugs.launchpad.net/bugs/102212
You received this bug notification because you are a member of MOTU,
which is a bug assignee.




More information about the universe-bugs mailing list