[ubuntu-za] Failed to load kernel modules

Paolo Gigante paolo.gigante.sa at gmail.com
Tue Feb 12 15:49:23 UTC 2019


Hi Bill,

As a starting point, I would unplug the 1TB completely and do a fresh
install on the SSD. I would also delete any pre-existing partitions on that
SSD and start from scratch (NB! Make sure you backup any data you want
before you blow it all away). That way you are hopefully eliminating any
interference from a previous install.

Personally I have not had the greatest experience with Ubuntu18 so I still
use 16.04 but that would be my first step in getting it working.

Once you get your system up and running, you can add the 1TB at a later
stage, you may need to adjust boot order in your bios if you have a boot
record on the 1TB.

On Tue, Feb 12, 2019 at 1:34 PM Bill Cairns <cairnsww at gmail.com> wrote:

> Hi All,
>
> I arrived home (after being away in Joeys for the weekend attending my
> grandson's 18th birthday party) and my Ubuntu 18.04 would not boot. it went
> most of the way through the boot process but then dropped into terminal
> mode and told me that ' we are in emergency mode'. The error message, a few
> lines above, says 'Failed to load Kernel Modules'.
>
> As I was quite keen on doing a clean up anyway, I thought that this was a
> good opportunity to do a fresh install. So I tried that. (I now think that
> this was a very poor decision, but there is no going back now
> unfortunately.)
>
> The install does not go through cleanly. At the end it gives me an error
> message that it could not clean up past packages or something. (I am sorry
> - I should have noted this down but didn't.) It then tells me to remove the
> installation media and reboot. I do, but the same error as before - Failed
> to load Kernel Modules.
>
> i have tried Googling this error but all the situations described do not
> come close to being the same as mine - usually people seem to get the eror
> after upgrading. I have not just upgraded and have been running 18.04 since
> July or August last year.I am afraid that the solutions that I read on
> Google confuse me completely and I have not understood them well enough to
> think of trying any of them.
>
> My configuration might be a bit unusual - I have a 1TB hard drive with my
> Home directory (and the boot sector). I also have a 128Mb SSD for the
> operating system. This has been running happily since October or so (and
> seems to work very well and fast).
>
> (I did trying installing the boot sector on the SSD but still get the same
> error.)
>
> I have no idea whether I am facing a hardware error or if I have somehow
> destroyed something important. The only extraordinary happenings have been
> some power failures - not only this week with load sharing but two strange
> ones last week before I went away.
>
> I would appreciate any ideas or pointers in the right direction.
>
> Bill
>
>
>
> --
> ubuntu-za mailing list
> ubuntu-za at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20190212/8d93d25c/attachment-0001.html>


More information about the ubuntu-za mailing list