[ubuntu-za] Upgrade error

Jan Greeff jan at verslank.net
Fri Oct 21 09:00:42 UTC 2016


Hi Anton, many thanks - I tried all the options on that page, the 
outcomes were:

*Synaptic:*


An error occurred

E: linux-image-extra-3.13.0-100-generic: subprocess installed 
post-removal script returned error exit status 1

E: linux-image-3.13.0-100-generic: subprocess installed post-removal 
script returned error exit status 1


*Terminal:*

jan at jan-System-Product-Name:~$ sudo dpkg --remove 
--force-remove-reinstreq --dry-run linux-image-3.13.0-100-generic

(Reading database ... 236379 files and directories currently installed.)

Would remove or purge linux-image-3.13.0-100-generic (3.13.0-100.147) ...

jan at jan-System-Product-Name:~$ sudo dpkg --remove 
--force-remove-reinstreq --dry-run linux-image-extra-3.13.0-100-generic

(Reading database ... 236379 files and directories currently installed.)

Would remove or purge linux-image-extra-3.13.0-100-generic 
(3.13.0-100.147) ...

jan at jan-System-Product-Name:~$ sudo dpkg --remove 
--force-remove-reinstreq linux-image-3.13.0-100-generic

(Reading database ... 236379 files and directories currently installed.)

Removing linux-image-3.13.0-100-generic (3.13.0-100.147) ...

Examining /etc/kernel/postrm.d .

run-parts: executing /etc/kernel/postrm.d/initramfs-tools 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

update-initramfs: Deleting /boot/initrd.img-3.13.0-100-generic

run-parts: executing /etc/kernel/postrm.d/zz-update-grub 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

/usr/sbin/grub-mkconfig: 36: /etc/default/grub: ^X: not found

run-parts: /etc/kernel/postrm.d/zz-update-grub exited with return code 127

Failed to process /etc/kernel/postrm.d at 
/var/lib/dpkg/info/linux-image-3.13.0-100-generic.postrm line 328.

dpkg: error processing package linux-image-3.13.0-100-generic (--remove):

subprocess installed post-removal script returned error exit status 1

Errors were encountered while processing:

linux-image-3.13.0-100-generic

jan at jan-System-Product-Name:~$ sudo dpkg --remove 
--force-remove-reinstreq linux-image-extra-3.13.0-100-generic

(Reading database ... 236379 files and directories currently installed.)

Removing linux-image-extra-3.13.0-100-generic (3.13.0-100.147) ...

depmod: FATAL: could not load /boot/System.map-3.13.0-100-generic: No 
such file or directory

run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-100-generic 
/boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/initramfs-tools 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

update-initramfs: Generating /boot/initrd.img-3.13.0-100-generic

grep: /boot/config-3.13.0-100-generic: No such file or directory

depmod: WARNING: could not open 
/tmp/mkinitramfs_l61Qos/lib/modules/3.13.0-100-generic/modules.order: No 
such file or directory

depmod: WARNING: could not open 
/tmp/mkinitramfs_l61Qos/lib/modules/3.13.0-100-generic/modules.builtin: 
No such file or directory

run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-100-generic 
/boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/update-notifier 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/zz-update-grub 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

/usr/sbin/grub-mkconfig: 36: /etc/default/grub: ^X: not found

run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 
127

dpkg: error processing package linux-image-extra-3.13.0-100-generic 
(--remove):

subprocess installed post-removal script returned error exit status 1

Errors were encountered while processing:

linux-image-extra-3.13.0-100-generic

jan at jan-System-Product-Name:~$


jan at jan-System-Product-Name:~$ sudo dpkg --force-remove-reinstreq 
--remove linux-image-extra-3.13.0-100-generic

(Reading database ... 236379 files and directories currently installed.)

Removing linux-image-extra-3.13.0-100-generic (3.13.0-100.147) ...

depmod: FATAL: could not load /boot/System.map-3.13.0-100-generic: No 
such file or directory

run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/dkms 3.13.0-100-generic 
/boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/initramfs-tools 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

update-initramfs: Generating /boot/initrd.img-3.13.0-100-generic

grep: /boot/config-3.13.0-100-generic: No such file or directory

depmod: WARNING: could not open 
/tmp/mkinitramfs_TxDHCf/lib/modules/3.13.0-100-generic/modules.order: No 
such file or directory

depmod: WARNING: could not open 
/tmp/mkinitramfs_TxDHCf/lib/modules/3.13.0-100-generic/modules.builtin: 
No such file or directory

run-parts: executing /etc/kernel/postinst.d/pm-utils 3.13.0-100-generic 
/boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/update-notifier 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

run-parts: executing /etc/kernel/postinst.d/zz-update-grub 
3.13.0-100-generic /boot/vmlinuz-3.13.0-100-generic

/usr/sbin/grub-mkconfig: 36: /etc/default/grub: ^X: not found

run-parts: /etc/kernel/postinst.d/zz-update-grub exited with return code 
127

dpkg: error processing package linux-image-extra-3.13.0-100-generic 
(--remove):

subprocess installed post-removal script returned error exit status 1

Errors were encountered while processing:

linux-image-extra-3.13.0-100-generic

jan at jan-System-Product-Name:~$


Then:

jan at jan-System-Product-Name:~$ sudo rm 
/var/lib/dpkg/info/linux-image-3.13.0-100-generic

rm: cannot remove ‘/var/lib/dpkg/info/linux-image-3.13.0-100-generic’: 
No such file or directory

jan at jan-System-Product-Name:~$ linux-image-extra-3.13.0-100-generic

linux-image-extra-3.13.0-100-generic: command not found

jan at jan-System-Product-Name:~$


Ran sudo apt-get autoremove:


Errors were encountered while processing:

linux-image-extra-3.13.0-100-generic

linux-image-3.13.0-100-generic

E: Sub-process /usr/bin/dpkg returned an error code (1)




On 21/10/2016 10:01, Anton May wrote:
> http://askubuntu.com/questions/490671/fix-half-installed-package
>
> On 21 October 2016 at 09:53, Jan Greeff <jan at verslank.net 
> <mailto:jan at verslank.net>> wrote:
>
>     Good day all,
>
>     Can somebody please assist me with this problem?
>
>     dpkg: error processing package linux-image-3.13.0-100-generic
>     (--configure):
>      package linux-image-3.13.0-100-generic is not ready for configuration
>      cannot configure (current status `half-installed')
>
>     I have Googled around to find a solution,
>     14.04 - "Package linux-image-generic is not configured yet." Error
>     - Ask Ubuntu
>     <http://askubuntu.com/questions/536525/package-linux-image-generic-is-not-configured-yet-error>
>
>     Revisions to dpkg: error processing package linux-image-generic
>     (--configure): dependency problems - leaving unconfigured - Ask
>     Ubuntu <http://askubuntu.com/posts/517857/revisions>
>     dpkg: error processing package linux-generic (--configure):
>     dependency problems - leaving unconfigured - Google Search
>     <https://www.google.com/search?q=dpkg%3A+error+processing+package+linux-generic+%28--configure%29%3A++dependency+problems+-+leaving+unconfigured&ie=UTF-8&sa=Search&channel=fe&client=browser-ubuntu&hl=en>
>
>     apt - dpkg: error processing package linux-image-generic
>     (--configure): dependency problems - leaving unconfigured - Ask
>     Ubuntu
>     <http://askubuntu.com/questions/517857/dpkg-error-processing-package-linux-image-generic-configure-dependency-pro>
>
>     install linux-image-extra-3.13.0-100-generic - Google Search
>     <https://www.google.com/search?client=ubuntu&channel=fs&q=install+linux-image-extra-3.13.0-100-generic&ie=utf-8&oe=utf-8>
>
>     Trusty (14.04) : linux package : Ubuntu
>     <https://launchpad.net/ubuntu/trusty/+source/linux>
>     E: Sub-process /usr/bin/dpkg returned an error code (1)
>     <https://ubuntuforums.org/showthread.php?t=1642173>
>
>     no success.
>
>     Best wishes,
>
>     Jan
>
>     --
>     ubuntu-za mailing list
>     ubuntu-za at lists.ubuntu.com <mailto:ubuntu-za at lists.ubuntu.com>
>     https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
>     <https://lists.ubuntu.com/mailman/listinfo/ubuntu-za>
>
>
>
>
> -- 
> Regards,
> Anton May
>
>

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20161021/4f233c69/attachment-0001.html>


More information about the ubuntu-za mailing list