[ubuntu-za] Fwd: Re: Howto use vodacom vodafone mobile modem K4305

Johan Scheepers johansche at telkomsa.net
Tue Jul 2 18:04:34 UTC 2013


On 02/07/2013 17:27, Miles wrote:
> -----Original Message-----
> From: Johan Scheepers <johansche at telkomsa.net>
> Reply-to: Ubuntu South African Local Community
> <ubuntu-za at lists.ubuntu.com>
> To: ubuntu-za <ubuntu-za at lists.ubuntu.com>
> Subject: [ubuntu-za] Fwd: Re: Howto use vodacom vodafone mobile modem
> K4305
> Date: Tue, 02 Jul 2013 15:50:16 +0200
> Mailer: Mozilla/5.0 (X11; Linux x86_64; rv:17.0) Gecko/20130623
> Thunderbird/17.0.7
>
>
>
>
> -------- Original Message --------
>                             Subject:
> Re: Fwd: Re: [ubuntu-za] Howto use
> vodacom vodafone mobile modem K4305
>                                Date:
> Tue, 02 Jul 2013 15:43:23 +0200
>                                From:
> Rita <27829291667 at vodamail.co.za>
>                                  To:
> Johan Scheepers
> <johansche at telkomsa.net>
>
>
> On 02/07/2013 12:29, Johan Scheepers wrote:
>
>>
>>
>> -------- Original Message --------
>>                            Subject:
>> Re: [ubuntu-za] Howto use vodacom
>> vodafone mobile modem K4305
>>                               Date:
>> Mon, 01 Jul 2013 11:05:05 +0200
>>                               From:
>> Miles <msdomdonner at gmail.com>
>>                           Reply-To:
>> Ubuntu South African Local
>> Community
>> <ubuntu-za at lists.ubuntu.com>
>>                                 To:
>> ubuntu-za at lists.ubuntu.com
>>
>>
>> sudo gedit /etc/init.d/mobile-broadband-connect
>> put in the following script change th 2 places where I have 8ta to your
>> 3g provider , I had to also change in nm where it showed 8.ta to just
>> 8ta and save and close
>>
>>
>>
>> #!/bin/sh
>> # Mobile Broadband Startup Service script v0.1 alpha by The Fan Club -
>> April 2012
>> # acts as startup service script for nmcli to fire up Mobile Broadband
>> Connections
>> # NOTE: Use the name of the Mobile Connection in the Network Manager as
>> the 'id'
>> # USAGE: start|stop|status
>> #
>> ### BEGIN INIT INFO
>> # Provides: mobile-broadband-connect
>> # Required-Start: $remote_fs $syslog
>> # Required-Stop: $remote_fs $syslog
>> # Should-Start: $network
>> # Should-Stop: $network
>> # Default-Start: 3 4 5
>> # Default-Stop: 0 1 6
>> # Short-Description: Autoconnect 3G GSM
>> ### END INIT INFO
>>
>> NAME="mobile-broadband-connect"
>> DESC="Autoconnect 3G/4G GSM USB modem at startup"
>>
>> test -x $DAEMON || exit 0
>>
>> case "$1" in
>> 	start)
>> 	   echo "Starting Mobile Broadband Connection."
>>
>> 	   while true; do
>>   	      # testing...
>> 	      LC_ALL=C nmcli -t -f TYPE,STATE dev | grep -q "^gsm:disconnected
>> $"
>> 	      if [ $? -eq 0 ]; then
>> 	         break
>>   	      else
>> 	         # no GSM modem detected yet, sleeping for a second
>> 	         sleep 1
>>   	      fi
>> 	   done
>>
>> 	   # Once GSM modem detected, run the script
>> 	   nmcli -t con up id vodacom
>> 	;;
>> 	stop)
>> 	   echo "Stopping Mobile Broadband Connection."
>> 	   nmcli -t con down id vodacom
>> 	   nmcli -t nm wwan off
>> 	;;
>> 	status)
>> 	   # Check to see if the process is running with nmcli
>>         nmcli -p dev
>> 	;;
>> 	
>> 	*)
>> 	   echo "Mobile Broadband Startup Service"
>> 	   echo $"Usage: $0 {start|stop|status}"
>> 	   exit 1
>> esac
>> exit 0
>>
>> sudo chmod +x /etc/init.d/mobile-broadband-connect
>>
>> To update the startup services
>>
>> sudo update-rc.d mobile-broadband-connect defaults
>>
>>   The script is registered as a system startup service so you can start,
>> stop, or check the status of the script with :
>>
>> sudo service mobile-broadband-connect start
>>
>> sudo service mobile-broadband-connect stop
>>   on rebooting mine worked and hasnt given problems since.
>> Good luck
>> Miles
> *****************************************************
> Good day Miles,
> Thanks for your reply.
> The exercise not succesfull.
> Kindly see below the output.
> The modem worked out of the box with this kernel..
> Linux rita 3.5.0-27-generic #46~precise1-Ubuntu SMP Tue Mar 26 19:33:21
> UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
> I then upgraded and the kernel changed..then no dice.
> With grub 2 customiser I have put it back.
> I tested with all the previous versions..no dice.
> This I tested on 2 different machines with the same operating systems
> and the outcome is the same.
> So kernel  xxxxxxxx-27 has something that the others do not have.
> Maybe the kernel people will put that back in the future.
> Johan S
>> root at rita:~# chmod +x /etc/init.d/mobile-broadband-connect
>> root at rita:~# update-rc.d mobile-broadband-connect defaults
>>   System start/stop links for /etc/init.d/mobile-broadband-connect already exist.
>> root at rita:~# service mobile-broadband-connect start
>> /etc/init.d/mobile-broadband-connect: 3: /etc/init.d/mobile-broadband-connect: April: not found
>> /etc/init.d/mobile-broadband-connect: 5: /etc/init.d/mobile-broadband-connect: Connections: not found
>> /etc/init.d/mobile-broadband-connect: 7: /etc/init.d/mobile-broadband-connect: the: not found
>> Starting Mobile Broadband Connection.
>> Error: Unknown connection: Vodacom.
>> root at rita:~# service mobile-broadband-connect stop
>> /etc/init.d/mobile-broadband-connect: 3: /etc/init.d/mobile-broadband-connect: April: not found
>> /etc/init.d/mobile-broadband-connect: 5: /etc/init.d/mobile-broadband-connect: Connections: not found
>> /etc/init.d/mobile-broadband-connect: 7: /etc/init.d/mobile-broadband-connect: the: not found
>> Stopping Mobile Broadband Connection.
>> Error: Unknown connection: Vodacom.
>> root at rita:~#
>>
>> ***********************************************
>>
>>
>>
>> Hi Johan, it is something to do with what you call your ISP I think. as I say I had to change 8.ta to 8ta
>> One of the dev guys at bugs sent me the script. Might even need to look like the above script with a small v
>> Do a bug report or go see the existing bugs and fixes. It looks to me like it doesnt see Vodacom
> Hi Miles, Quite right. None of the kernels see it in Mint 15, Wheezy, Raring.
Only kernel that sees it is

  3.5.0-27-generic. Thats it so far. Thanks for trying.
Johan S


>
>
>
>
>
>
>




More information about the ubuntu-za mailing list