[ubuntu-za] Root user in Ubuntu

Henk Joubert jouberthenk at gmail.com
Sun Sep 9 08:25:18 UTC 2012


You could try sudo -i to get root privileges with your account for a
session. You should then be able to set a root password using "passwd
root", but I would advise against doing this on any machine that is somehow
accessible by others. I can't remember what the root users default home
directory is, but it's probably / or /root in ubuntu, you can change it in
/etc/passwd [
http://www.cyberciti.biz/faq/understanding-etcpasswd-file-format/].

https://help.ubuntu.com/community/Java has instructions for installing Sun
Java that seem rather straightforward.

On 9 September 2012 08:40, Nico Michael(iBurst)
<nick.michael at ptaisp.co.za>wrote:

>  Hi there
>
> *I need to work as root user *
> I need to enable the root user and set the root user password in my Ubuntu
> workstation in a VM
> I could do sudu su but I need to login with full root as the root user
>
> *This is in a VM and risks mitigated*
> Regarding risks this is a VM so I will make an image in the VMware  server
> to recover from damage.
>
> *How do I set root password*
> I know is solaris you would use a passwd command to set the root user's
> password
>
> *What is root home directory*
> I also know in solaris the root users home directory in not /home/root
> what is it in Ubuntu Linux?
> *
> **The root or sudo user cant see programs pathed for non-root users how
> do I fix that*
> Also I have seen certain program  ran when you logged in as non-root user
> which  did not get pathed and did not run on a Centos Server when you
> logged in as root
>
> *I need to run Sun Java not the non-industry non-standard Java Ubuntu
> provides*
> One of the problems all professional Java developers have with Ubuntu is
> we need to use the Industry standard so our programs work Ubuntu tends to
> install its own "Non-Industry non-standard" Java
> Which we always have to remove and then it becommes a mission to get Sun
> java to work
>
> *To get Sun Java running on Ubuntu*
> I remove the "Ubuntu supplied non-standard Java" then I edit /etc/profile
> and add JAVA_HOME="/usr/lib/jvm/java-6-sun-1.0.0.30  and then export
> JAVA_HOME
>
> *Java does not run as the sudo or root user*
> This works when I run      java -version                      I get the
> right version of Java
> how ever when I run         sudo java -version            It cant find Java
>
>  which file and or older do you put path information  so the Root or SUDO
> user can find the Java ?
>
>
> Please advise
>
> --
>
>
> Kind Regards
>
> Nico Michaelhttp://www.arduino.org.za
>
>
> --
> ubuntu-za mailing list
> ubuntu-za at lists.ubuntu.com
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
>
>


-- 
Henk Joubert
BSc Computer Science (Hons) | University of Cape Town 2012
jouberthenk at gmail.com | <henk at algorithm.cs.uct.ac.za> 0836382339
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-za/attachments/20120909/d33fe888/attachment.html>


More information about the ubuntu-za mailing list