[ubuntu-za] wvdial and Huawei E220

Bruce Pieterse dev at otq.za.net
Sat Jul 21 19:56:08 UTC 2012


On 21/07/2012 20:34, Wesley Werner wrote:
> Hello,
>
> I need another pair of eyes or some fresh ideas.
>
> I have a 3G Huawei E220 modem. the thing works via network-manager's
> nm-applet, but not via wvdial. This is on a bare-bones WM without a
> panel/icons tray.
>
> wvdialconfg says 'no modem detected', but I manually configured it to my
> known-working device and it recognizes the ATZ commands. It fails with a
> 'invalid dial command'.
>
> I tried:
> - internet and vdata APN setting (virgin sim)
> - dial commands *99# and *99***1#
> - updating usb_modeswitch to latest version
>
> any tips? thanks :-)
>
>
> *full output*
>
> :~$ sudo wvdial thenet
> --> WvDial: Internet dialer version 1.60
> --> Cannot get information for serial port.
> --> Initializing modem.
> --> Sending: ATZ
> OK
> --> Sending: ATZ
> OK
> --> Sending: ATE0V1&D2&C1S0=0+IFC=2,2
> OK
> --> Sending: AT+CGDCONT=1,"IP","vdata"
> OK
> --> Modem initialized.
> --> Sending: ATDT*99***1#
> --> Waiting for carrier.
> ERROR
> --> Invalid dial command.
>
>
>
Perhaps these three posts could help you extract more information:
-
http://www.noulakaz.net/weblog/2007/12/16/emtels-huawei-e220-with-linux-in-mauritius/
-
http://mybroadband.co.za/vb/showthread.php/110051-Virgin-Mobile-Huawei-E220-Kubuntu
- http://www.understated.co.uk/2007/virgin-mobile-3g-modem-with-ubuntu/

-- 
All the best,

Bruce

FSF Member 10674 / The FSF is a charity with a worldwide mission to advance software freedom / Join the Free Software Foundation: http://www.fsf.org/register_form?referrer=10674




More information about the ubuntu-za mailing list