[ubuntu-za] add repo

Miles msdomdonner at gmail.com
Mon Feb 20 10:45:42 UTC 2012


-----Original Message-----
From: frans <dormakorp at vodamail.co.za>
Reply-to: Ubuntu South African Local Community
<ubuntu-za at lists.ubuntu.com>
To: ubuntu-za at lists.ubuntu.com
Subject: Re: [ubuntu-za] add repo
Date: Fri, 17 Feb 2012 11:58:41 +0200
Mailer: Mozilla/5.0 (Windows NT 5.1; rv:10.0.1) Gecko/20120208
Thunderbird/10.0.1



On 12/02/17 08:48, Miles wrote:
> -----Original Message-----
> From: Hannes Coetzee<scorpking at scorpking.za.org>
> Reply-to: Ubuntu South African Local Community
> <ubuntu-za at lists.ubuntu.com>
> To: Ubuntu South African Local Community<ubuntu-za at lists.ubuntu.com>
> Subject: Re: [ubuntu-za] add repo
> Date: Fri, 17 Feb 2012 01:20:27 +0200
> Mailer: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2.17)
> Gecko/20110516 Thunderbird/3.1.10
>
> On 16/02/2012 18:31, Miles wrote:
>> <--SNIP-->
>> I find it hard to believe that if, on a clean install. one copys the
>> whole /var/cache/apt/archives from a working machine or local repo that
>> the simple command like sudo apt-get update doesn look whats in your
>> archives till it has first gone online to see whats inna sky. there must
>> be a way to make update see whats available already on your pc?
>>
> The reason why that won't work is because apt stores a list of the
> available packages in /var/cache/apt/pkgcache.bin and
> /var/cache/apt/srcpkgcache.bin when you run apt-get update. If you do a
> fresh install the list of available packages in those files will be
> different from the available packages on your old machine. In theory I
> suppose you could copy those two files as well to the new machine and it
> should work but I've never tried it. It might be worth testing.
>
> Hannes
>
>
> Hi Hannes, Gonna try this as well. I have tried copying
> /var/lib/apt/ and /var/cache/apt/ and /var/cache/apt/archives but
> without update first going online for the update it doesnt look whats
> already in archives. if I can tell update to look whats already in /var/
> without wanting to go online I will most likely fall off the chair
> because then I can use maverick forever.
> Thanks for the help guys
> Miles
>
>
It might be worth trying /dpkg -i *.deb/ in a folder with the deb files ...
Three things though :
For some reason there usually are some files missing...
and you would need to fix broken packages afterwards (probably)

Installing the restricted extras still need data to download some of the 
fonts...

-- 
  When working on a computer you have to know enough:
  To fake what you don't know.
  Google what you can't fake.
  How (and when) to 'motivate' the computer to do what Google won't tell.

Frans de Waal
IT Manager/
Dormakorp



Thanks Frans. strong command that. I wonder why there are broken
packages. If one installs the packages with gdebi there isnt one broken
one. only prob is you have to try install one then it says dependancies
arent met so you find the dependancies first, install them, then go back
to what you wanted to install. Painfully slow episode. I tried with
aptoncd and it works great. sorts a new install like your working
system. Why dont you guys join us on irc tonight for #ubuntu-za 's
monthly meeting.
Thanks again.
Miles




More information about the ubuntu-za mailing list