[ubuntu-za] No sound

Bill Cairns cairnsww at gmail.com
Sat May 22 09:05:17 BST 2010


On Fri, May 21, 2010 at 6:29 PM, David Robert Lewis (ethnopunk)
<ethnopunk at mweb.com> wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
>
> Hi, Bill,
>
> Had a bit of sound trouble a while back, and reinstalling the sound
> server fixed it, check this thread.
>
> http://ubuntuforums.org/showthread.php?t=1359187
>

BAYETE! (I am playing that now!)

Thanks very much - it sort of worked! I presume that I had the wrong
driver version installed (from the RC rather than the final release of
10.04) and forcing the reinstall has brought everything back into
sync.

When I say 'sort of'', the commands given did not work and I had to
manipulate them - see below. But I have sound now, albeit rather
scratchy sound. (It seems that every mouse movement comes through as a
'scratch'. It was doing that before the fix - the only sound that I
had. I can minimize it by turning down the volume control on the
speakers and increasing the sound control volume at the top right of
my screen).

The commands from the website (from a garvinrick4 are:
1. Backup (and then delete) your previous configuration files:
Code:
$ mkdir ~/pulse-backup && cp -r ~/.pulse ~/.asound* /etc/asound.conf
/etc/pulse -t ~/pulse-backup/ $ rm -r ~/.pulse ~/.asound* $ sudo rm
/etc/asound.conf

[This command did not work - but I just split it into the three
constituent commands and it worked fine].


2. Ensure you have the necessary PulseAudio libraries and
configuration utilities installed:
Code:
$ sudo apt-get install libasound2-plugins padevchooser
libsdl1.2debian-pulseaudio

[Well it said was that I already had the latest versions installed of
all of those. So I went to Synaptic and forced a re-install of all
four packages].


3. Ensure the evil "libflashsupport" library is not installed:
Code:
$ sudo apt-get remove --purge libflashsupport flashplugin-nonfree-extrasound

[It wasn't!]



More information about the ubuntu-za mailing list