[ubuntu-za] NFS Problems

Erasmus, P, Mnr <perasmus@sun.ac.za> perasmus at sun.ac.za
Fri Feb 12 11:30:16 GMT 2010


Hi Guys,

 

I am really desperate for help with the following issue, I will try to give all the info in the mail but if I missed something please feel free to ask. I am running a Dell PE2850 server with VMware Esxi 3.5 installed with scsi and 2* 3.0GHz Xeon 1GIG nic. The virtual host has 4GB memory and the following disk configuration(See Below).  I am running Ubuntu 8.04 on the vm with NFS,POSTFIX and IMAPS configured.  The problem I am having is that the nfs server locks up when there is a lot of students logging in at once. I have a slapd server running on the network for authentication in slapd I also configure that the home directory is mounted from the nfs host on the client, so if the nfs server goes down nobody can work because it can’t mount the home drive on the Intrepid 8.10 client machine. There is a high number of mount request to the server daily but on Thursday the amount is double and that is when the server acts up.  It just gives a brown screen. Only thing that repairs this is rebooting the nfs server. Please find the server and client configs pasted in this mail. I am waiting for 10 GB more memory I have also increased the  # Number of servers to start up

RPCNFSDCOUNT=16 default was 8(I also tried 24), but still no luck. Was also thinking of setting the mount options to soft on the home drive (then the client should still log in fine even if there is timeouts to the server or the server is lockd am I correct)

Server:

Kernel Version: 2.6.24-24-server

ii  libnfsidmap2                       0.20-0build1                An nfs idmapping library

ii  nfs-common                      1:1.1.2-2ubuntu2.2       NFS support files common to client and serve

ii  nfs-kernel-server               1:1.1.2-2ubuntu2.2       support for NFS kernel server

 /dev/sda1             1.9G  420M  1.5G  22% /
varrun                1.9G   76K  1.9G   1% /var/run
varlock               1.9G     0  1.9G   0% /var/lock
udev                  1.9G   64K  1.9G   1% /dev
devshm                1.9G     0  1.9G   0% /dev/shm
/dev/sda5             1.9G   33M  1.9G   2% /tmp
/dev/sda2             1.9G  468M  1.5G  25% /usr
/dev/sda7              13G  2.7G   10G  22% /var
/dev/sdb1             150G   94G   57G  63% /home

 /dev/sdb1 on /home type reiserfs (rw,noatime,relatime,usrquota)

 /etc/exports

/home   *.example.co.za(rw,sync,no_subtree_check)
 

Server rpc stats:

calls      badcalls   badauth    badclnt    xdrcall

1305947    0          0          0          0

 

threads

th 16 30288 192.590 18.140 21.430 7.580 14.660 14.150 8.290 18.000 18.560 37.540

 

Client:

I mount the drives with autofs

/etc/auto.home

*       -fstype=nfs,rsize=8192,wsize=8192,nodev,nosuid  test.example.com:/home/&

 

SYSLOG ERR on server:

 

Feb 11 14:01:34 example rpc.statd[4486]: Can't callback hostname (100021,3), giving up.

Feb 11 13:57:30 hostname mountd[4940]: can't stat exported dir /home/buildmeister: No such file or directory (Think this is a student booting from usb – also getting same error that is looking for .directory .hidden .hg – got a way around this by creating file with full permissions but it could not be long time solution)

 

Paul 


More information about the ubuntu-za mailing list