[ubuntu-za] Post intrepid 'no sound' problem - ALSA, PulseAudio, & drivers

Péter Nel petern2 at openweb.co.za
Wed Jan 14 11:05:37 GMT 2009


-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

Hi all,

I really hope someone can help me. I've had no sound since upgrading
to Intrepid (~ 2 months).
Audio & mic worked in hardy (*) and previous releases.

I've gone through most of
https://help.ubuntu.com/community/SoundTroubleshooting
(stopping short of driver compilation and replacing alsa with OSS)
It doesn't go into pulseaudio, and only mentions it at the end.

I've tried various other things, including disabling pulseaudio to use
alsa-to-hardware directly.
(as described here -
http://idyllictux.wordpress.com/2008/10/29/alsa-instead-of-pulseaudio-for-ubuntu-810-intrepid-a-non-destructive-way/)
## current state of my system, sort of ##

Some of the arb things tried from googling around may have left some
of the config files in a conflicting state??

I've tried the #ubuntu channel on freenode, but nothing yet.

(*) I think a similar thing happened after upgrading to hardy (i
remember having mic problems) - as far as I know pulse audio was
introduced in hardy.

I would prefer a working PulseAudio configuration since the solution
seems more elegent (allowing multiple simultaneous access to the sound
server/device)

Some of my audio related info:
#####################
$ asoundconf list
Names of available sound cards:
nForce2

$ lspci
## audio section only ##
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97
Audio Controler (MCP) (rev a1)
    Subsystem: Micro-Star International Co., Ltd. Device 5700
    Flags: bus master, 66MHz, fast devsel, latency 0, IRQ 21
    I/O ports at b000 [size=256]
    I/O ports at b400 [size=128]
    Memory at ec001000 (32-bit, non-prefetchable) [size=4K]
    Capabilities: <access denied>
    Kernel driver in use: Intel ICH
    Kernel modules: snd-intel8x0

$ lsmod |grep snd
snd_intel8x0           37532  1
snd_ac97_codec        111652  1 snd_intel8x0
ac97_bus                9856  1 snd_ac97_codec
snd_pcm_oss            46848  0
snd_mixer_oss          22784  1 snd_pcm_oss
snd_pcm                83204  3 snd_intel8x0,snd_ac97_codec,snd_pcm_oss
snd_seq_dummy          10884  0
snd_seq_oss            38528  0
snd_seq_midi           14336  0
snd_rawmidi            29824  1 snd_seq_midi
snd_seq_midi_event     15232  2 snd_seq_oss,snd_seq_midi
snd_seq                57776  6
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_seq_midi_event
snd_timer              29960  2 snd_pcm,snd_seq
snd_seq_device         15116  5
snd_seq_dummy,snd_seq_oss,snd_seq_midi,snd_rawmidi,snd_seq
snd                    63268  12
snd_intel8x0,snd_ac97_codec,snd_pcm_oss,snd_mixer_oss,snd_pcm,snd_seq_oss,snd_rawmidi,snd_seq,snd_timer,snd_seq_device
soundcore              15328  1 snd
snd_page_alloc         16136  2 snd_intel8x0,snd_pcm

$ aplay -l
# Q: why are there two devices? I only have plain onboard audio
(mic,line,spk) #
**** List of PLAYBACK Hardware Devices ****
card 0: nForce2 [NVidia nForce2], device 0: Intel ICH [NVidia nForce2]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: nForce2 [NVidia nForce2], device 2: Intel ICH - IEC958 [NVidia
nForce2 - IEC958]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

$ skype
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
ALSA lib pcm.c:2196:(snd_pcm_open_noupdate) Unknown PCM cards.pcm.hdmi
bt_audio_service_open: connect() failed: Connection refused (111)
bt_audio_service_open: connect() failed: Connection refused (111)
... repeat ...

$ aplay Beatles\ -\ a\ hard\ days\ night.mp3
Playing raw data 'Beatles - a hard days night.mp3' : Unsigned 8 bit,
Rate 8000 Hz, Mono
# note: silience.. no errors? #

$ audacious
amidi-plug(amidi-plug.c:amidiplug_init:97): init, read configuration
amidi-plug(i_backend.c:i_backend_load:107): loading backend
'/usr/lib/audacious/Input/amidi-plug/ap-alsa.so'
amidi-plug(i_backend.c:i_backend_load:145): backend
/usr/lib/audacious/Input/amidi-plug/ap-alsa.so (name 'alsa')
successfully loaded
# note: also seems fine, but silent when i play a song #
#####################

It seems like it should be playing... audacious even wiggles the
little scope visualizer to the silent beat (audacious audio pref is
set to use the "ALSA output plugin"
Desktop speakers are plugged in and powered. Headphones also don't work.
Main and PCM in Alsamixer is unmuted, and the selected device in
gnome-volume-control is "NVidia nForce2 (Alsa Mixer)"
( there's also a selectable "Realtek ALC 650F (OSS Mixer)", but also
doesn't work even if selecting "OSS output plugin" in audacious, tho i
don't think oss is properly set up )
Everything in gnome-sound-properties gui is set to use ALSA

I'm using XFCE (XUbuntu) but logging into a Gnome session yields
similar results.

Damn (vent alert!..): It used to work. I thought we were past this
kind of problem. A single issue like this might kill the entire OS for
some people.
Luckily I'm a die hard ubuntero.

- --
Péter Nel
_______________________________________________
"They who would give up an essential liberty for temporary security,
deserve neither liberty nor security"
           - Benjamin Franklin
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.9 (GNU/Linux)
Comment: Using GnuPG with Mozilla - http://enigmail.mozdev.org

iEYEARECAAYFAkltxwEACgkQVeyk97gakq5FIACgs1yavAvQx/M8ty31ardD5x2W
QPQAnjwGF4LotsXpy3LqiMcDroY79P0Y
=awy9
-----END PGP SIGNATURE-----




More information about the ubuntu-za mailing list