[ubuntu-za] Xfix, problem with video

David Robert Lewis ethnopunk at yahoo.co.uk
Sun Feb 8 16:17:35 GMT 2009



Thanks so much Hannes, and everybody else this one worked. My graphics is back, and I've learnt how to change the runlevels in the process. Wish things were simpler. Now the original problem that made me xfix in the first place is plaguing me. It has to do with my router. I have a duel boot, and its working fine with XP. It was working okay with Ubuntu, but I noticed my Ubuntu slowing down. If tried reconfiguring the router but nothing. Also tried setting up using the instruction in the help.

afrodeity at afrodeity-desktop:~$ sudo pppoeconf
sudo: unable to resolve host afrodeity-desktop
afrodeity at afrodeity-desktop:~$ 

So still can't use the sudo command! What is going on, did somebody try to hack into may system from somewhere?








________________________________
From: Hannes Coetzee <scorpking at scorpking.za.org>
To: Ubuntu South African Local Community <ubuntu-za at lists.ubuntu.com>
Sent: Sunday, 8 February, 2009 16:50:40
Subject: Re: [ubuntu-za] Xfix, problem with video

press <esc> when the computer boot to get to the grub menu. start in 
recovery mode and get into the root shell. you should not have to edit 
any files. try this:

cd /etc/X11/
ls -ltr xorg.co*

it should show something like:
-rw-r--r-- 1 root root 1225 2008-06-29 00:32 
/etc/X11/xorg.conf.20080629003247   <-- older xorg.conf backup
-rw-r--r-- 1 root root 1225 2008-06-30 15:05 
/etc/X11/xorg.conf.1                             <-- older xorg.conf backup
-rw-r--r-- 1 root root 1225 2008-08-27 19:30 
/etc/X11/xorg.conf.20080827193042   <-- older xorg.conf backup
-rw-r--r-- 1 root root 1225 2008-08-27 19:55 /etc/X11/xorg.conf.working
-rw-r--r-- 1 root root 1326 2008-09-19 00:54 
/etc/X11/xorg.conf.2                             <-- xfix moved 
xorg.conf to here before creating xorg.conf again
-rw-r--r-- 1 root root 3378 2008-09-19 00:54 /etc/X11/xorg.conf
scorpking at scorpking-desktop:~$

as you can see i always keep a working copy as a backup. the second last 
line contains the last used config file that was in use before xfix was 
ran. to get it back run:

cp xorg.conf.2 xorg.conf

please replace xorg.conf.2 with the second last filename showing on your 
computer. after that type exit and select resume. if it does not work 
copy the third file to xorg.conf and so on... if you need to edit 
xorg.conf from cli use nano or vim 
(http://www.tuxfiles.org/linuxhelp/vimcheat.html)

good luck
hannes





David Robert Lewis wrote:
>
> Okay, not sure if this is the right method, but I've booted normally. 
> Then I've used ctrl-alt-F2 to log on. This gives me a nice blank 
> screen and command prompt for my @desktop. I can see my X11 folder and 
> the files I need to edit. Only problem is sudo doesn't seem to work 
> here. I can only open a blank document same as if you use gedit and 
> call up a .conf file without the sudo and can't save anything. 
> Permision denied, or cannot resolve @desktop. What am I doing wrong?
>
>
> ------------------------------------------------------------------------
> *From:* Tim Johnson <tim at pteq.net>
> *To:* Ubuntu South African Local Community <ubuntu-za at lists.ubuntu.com>
> *Sent:* Sunday, 8 February, 2009 15:49:56
> *Subject:* Re: [ubuntu-za] Xfix, problem with video
>
> In Terminal run
>
> sudo gedit
>
> Then use Open to find the file in /etc/X11/
>
> On Sun, 08 Feb 2009 15:39:34 +0200, David Robert Lewis 
> <ethnopunk at yahoo.co.uk <mailto:ethnopunk at yahoo.co.uk>> wrote:
>
> >
> > I dropped down to shell, but can't seem to find /etc/X11. I've used cd 
> > to change into /etc, but X11 is not listed. I can see if from another 
> > partition, but not inside the Ubuntu installation. Where is it, am I 
> > navigating right, is there another command I should use?
> >
> >
> >
> >
> > ________________________________
> > From: Hannes Coetzee <scorpking at scorpking.za.org 
> <mailto:scorpking at scorpking.za.org>>
> > To: Ubuntu South African Local Community <ubuntu-za at lists.ubuntu.com 
> <mailto:ubuntu-za at lists.ubuntu.com>>
> > Sent: Sunday, 8 February, 2009 15:08:08
> > Subject: Re: [ubuntu-za] Xfix, problem with video
> >
> > there might be a backup of your original xorg.conf file in /etc/X11/
> > .copy it back to xorg.conf and test it. as far as i know xfix always
> > makes a backup.
> >
> > David Robert Lewis wrote:
> >> Here's the problem - I booted Ubuntu in Recover Mode and did an Xfix,
> >> because my computer was slowing down. Original problem of slowing down
> >> is fixed (modem issue), but now my video graphics is a fuzzy stripe
> >> haze. I have tried dropping down to shell and using dpkg-reconfigure
> >> but no luck. All I get is a list of options to do with my keyboard and
> >> mouse, nothing about video. What should I do, please help.
> >>
> >
> >
>
>
>
> -- 
> Using Opera's revolutionary e-mail client: http://www.opera.com/mail/
>
>
> -- 
> ubuntu-za mailing list
> ubuntu-za at lists.ubuntu.com <mailto:ubuntu-za at lists.ubuntu.com>
> https://lists.ubuntu.com/mailman/listinfo/ubuntu-za
>

-- 
ubuntu-za mailing list
ubuntu-za at lists.ubuntu.com
https://lists.ubuntu.com/mailman/listinfo/ubuntu-za



      
-------------- next part --------------
An HTML attachment was scrubbed...
URL: https://lists.ubuntu.com/archives/ubuntu-za/attachments/20090208/0e23e5d5/attachment-0001.htm 


More information about the ubuntu-za mailing list