[ubuntu-za] problem with synaptic package manager

Jason Norwood-Young jason at tectonic.co.za
Sun May 7 17:01:53 BST 2006

Dimitri Mallis wrote:
> thanks i tried :-> gksudo synaptic & it worked. i dont know what was 
> wrong. once i tpyed that in i got the pakage manager. once i closed it 
> every thing that did not respond now did
> ...strange, but im glad i didnt have to try all the geek stuff
> i down graded from gcc4 to gcc 3.4.6 so that i could build drivers for 
> my mother board (Nforce 4, 64bit, but im using 32bit linux)
> i got gcc 3.4.6, unpacked it, did
> ./configure
> make
> make install
> everything went fine, i rebooted
> the nVidea installer does not see the right gcc version, because when 
> i type gcc -ver in the shell it sais 3.4.6
> any help on that?
Why you fiddling with this stuff for NVidia support? Add Seveas' 
repository (http://users.lichtsnel.nl/~seveas/) and just get the drivers 
through Synaptic, save yourself one large headache.

If you really really want to build your own drivers and you're having 
problems with your GCC version, set the CC environment variable to get 
make to compile against a different version of GCC. (you'll need the 
version installed of course.) Something like export CC=gcc-4.0

And are you building GCC??? Use Synaptic or you're going to toast your 
system sooner rather than later. Vers 2.95, 3.3, 3.4 and 4.0 are all 
available in the repositories.


More information about the ubuntu-za mailing list