[ubuntu-x] fglrx support in Natty

Alberto Milone alberto.milone at canonical.com
Wed Mar 30 14:44:52 UTC 2011

Hi all,

A new fglrx driver (2:8.840-0ubuntu1) is now available in Natty and it
finally works with the new xserver. There are still a few issues whose
fixes should land after Beta 1 is released:

1) compiz needs to be updated so that fglrx can work with Unity.
Currently the "Classic Desktop" session works well but the "Ubuntu
Desktop" one doesn't. If you'd like to test Unity with the new driver,
you can use Unity's daily builds from the PPA, as described here:

2) currently the driver is not offered for installation in Jockey. A fix
is already available in Jockey's development branch though.

In the meantime, if you wish to install the new fglrx driver, you can do
it manually by following these commands:

sudo apt-get install fglrx
sudo update-alternatives --config gl_conf (and select the line with fglrx)
sudo update-initramfs -u

and finally reboot.

No xorg.conf is required as the driver will be automatically loaded.

Note: despite what the relevant article from Phoronix claims, the driver
doesn't support AMD's PowerXpress.


Alberto Milone
Sustaining Engineer (system)
Premium Engagements Team
Canonical OEM Services

More information about the Ubuntu-x mailing list