<html><head></head><body><div>Hello User Tech Support  </div><div><br></div><div>I get error "Failed to download repository information. Check your Internet connection."</div><div><br></div><div>I saw so much news from Ubuntu about snaps that I thought it was time I learnt more.</div><div><br></div><div>So I found the tutorial on the website :</div><div><br></div><div><a href="https://tutorials.ubuntu.com/tutorial/basic-snap-usage#1">https://tutorials.ubuntu.com/tutorial/basic-snap-usage#1</a></div><div><br></div><div>I am a retired Ubuntu end-user so I tried just reading the steps first. Then I tried to install snapd. </div><div>That showed 41 packages were "no longer required" as you will see from the clips of terminal session messages quoted below.</div><div><br></div><div>I am preparing to upgrade to Ubuntu 18.04.1 and am deleting lots of old files. That is why I decided to remove the "no longer required" as the messages told me. </div><div>Big mistake. The removal ran for maybe an hour and then the software repositories were not accessible. </div><div>"Failed to download repository information. Check your Internet connection."</div><div><div>I don't know why apt could not connect to the network because I was able to access other websites. </div><div>Maybe the removal disabled the connection??</div><div><br></div></div><div>I hope you will be able to tell me how to correct the situation!!</div><div>*************************************</div><div><br></div><div><a href="mailto:chas@Charles-PC">chas@Charles-PC</a>:~$ sudo apt install snapd</div><div>[sudo] password for chas: </div><div>Reading package lists... Done</div><div>Building dependency tree       </div><div>Reading state information... Done</div><div>The following packages were automatically installed and are no longer required:</div><div>  libllvm4.0 libllvm5.0 libqmi-glib1 libqpdf17 linux-headers-4.4.0-101</div><div>  linux-headers-4.4.0-101-generic linux-headers-4.4.0-103</div><div>  linux-headers-4.4.0-103-generic linux-headers-4.4.0-104</div><div><snip></div><div>linux-headers-4.4.0-81-generic linux-headers-4.4.0-83</div><div>  linux-headers-4.4.0-83-generic linux-headers-4.4.0-87</div><div><snip></div><div>linux-headers-4.4.0-98-generic linux-image-4.4.0-101-generic</div><div>  linux-image-4.4.0-103-generic linux-image-4.4.0-104-generic</div><div><snip></div><div>linux-image-extra-4.4.0-103-generic linux-image-extra-4.4.0-104-generic</div><div>  linux-image-extra-4.4.0-109-generic linux-image-extra-4.4.0-112-generic</div><div><snip></div><div><font color="#ff0000">Use 'sudo apt autoremove' to remove them.</font></div><div><font color="#ff0000">The following packages will be upgraded:</font></div><div><font color="#ff0000">  snapd</font></div><div><font color="#ff0000">1 to upgrade, 0 to newly install, 0 to remove and 12 not to upgrade.</font></div><div><font color="#ff0000">Need to get 14.1 MB of archives.</font></div><div><font color="#ff0000">After this operation, 1,167 kB of additional disk space will be used.</font></div><div><font color="#ff0000">Err:1 <a href="http://ubuntu.mirror.neology.co.za/ubuntu">http://ubuntu.mirror.neology.co.za/ubuntu</a> xenial-updates/main amd64 snapd amd64 2.33.1ubuntu2</font></div><div><font color="#ff0000">  Cannot initiate the connection to ubuntu.mirror.neology.co.za:80 (2001:43e8:10:42::25). - connect (101: Network is unreachable) [IP: 2001:43e8:10:42::25 80]</font></div><div><font color="#ff0000">E: Failed to fetch <a href="http://ubuntu.mirror.neology.co.za/ubuntu/pool/main/s/snapd/snapd_2.33.1ubuntu2_amd64.deb">http://ubuntu.mirror.neology.co.za/ubuntu/pool/main/s/snapd/snapd_2.33.1ubuntu2_amd64.deb</a>  Cannot initiate the connection to ubuntu.mirror.neology.co.za:80 (2001:43e8:10:42::25). - connect (101: Network is unreachable) [IP: 2001:43e8:10:42::25 80]</font></div><div><br></div><div>E: Unable to fetch some archives, <u><font color="#ff00ff">maybe run apt-get update</font></u> or try with --fix-missing?</div><div><a href="mailto:chas@Charles-PC">chas@Charles-PC</a>:~$ sudo apt autoremove</div><div><snip></div><div>Removing linux-image-4.4.0-98-generic (4.4.0-98.121) ...</div><div>Examining /etc/kernel/postrm.d .</div><div>run-parts: executing /etc/kernel/postrm.d/initramfs-tools 4.4.0-98-generic /boot/vmlinuz-4.4.0-98-generic</div><div>update-initramfs: Deleting /boot/initrd.img-4.4.0-98-generic</div><div>run-parts: executing /etc/kernel/postrm.d/zz-update-grub 4.4.0-98-generic /boot/vmlinuz-4.4.0-98-generic</div><div>Generating grub configuration file ...</div><div>Found linux image: /boot/vmlinuz-4.4.0-130-generic</div><div>Found initrd image: /boot/initrd.img-4.4.0-130-generic</div><div>Found linux image: /boot/vmlinuz-4.4.0-128-generic</div><div>Found initrd image: /boot/initrd.img-4.4.0-128-generic</div><div>Found linux image: /boot/vmlinuz-3.13.0-92-generic</div><div>Found initrd image: /boot/initrd.img-3.13.0-92-generic</div><div>Found memtest86+ image: /boot/memtest86+.elf</div><div>Found memtest86+ image: /boot/memtest86+.bin</div><div>Found Windows 7 (loader) on /dev/sda1</div><div>done</div><div>Processing triggers for libc-bin (2.23-0ubuntu10) ...</div><div><a href="mailto:chas@Charles-PC">chas@Charles-PC</a>:~$ </div><div><snip></div><div>W:Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:49 and /etc/apt/sources.list.d/xenial-partner.list:4, </div><div>W:Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:49 and /etc/apt/sources.list.d/xenial-partner.list:4,</div><div><snip></div><div>W:The repository '<a href="http://ubuntu.mirror.neology.co.za/ubuntu">http://ubuntu.mirror.neology.co.za/ubuntu</a> xenial Release' does not have a Release file., </div><div>W:Data from such a repository can't be authenticated and is therefore potentially dangerous to use., </div><div>W:See apt-secure(8) manpage for repository creation and user configuration details.,</div><div><snip></div><div>E:Failed to fetch <a href="http://ubuntu.mirror.neology.co.za/ubuntu/dists/xenial-backports/restricted/source/Sources">http://ubuntu.mirror.neology.co.za/ubuntu/dists/xenial-backports/restricted/source/Sources</a>  </div><div>Cannot initiate the connection to ubuntu.mirror.neology.co.za:80 (2001:43e8:10:42::25). - connect (101: Network is unreachable) [IP: 2001:43e8:10:42::25 80]</div><div><snip></div><div>E:Some index files failed to download. They have been ignored, or old ones used instead.</div><div><snip></div><div><a href="mailto:chas@Charles-PC">chas@Charles-PC</a>:~$ sudo apt-get update</div><div>[sudo] password for chas: </div><div>Hit:1 <a href="https://deb.opera.com/opera-stable">https://deb.opera.com/opera-stable</a> stable InRelease</div><div>Hit:2 <a href="http://archive.canonical.com/ubuntu">http://archive.canonical.com/ubuntu</a> xenial InRelease                                                  </div><div>Ign:3 <a href="http://ubuntu.mirror.neology.co.za/ubuntu">http://ubuntu.mirror.neology.co.za/ubuntu</a> xenial InRelease                      </div><div>Ign:4 <a href="http://ubuntu.mirror.neology.co.za/ubuntu">http://ubuntu.mirror.neology.co.za/ubuntu</a> xenial-updates InRelease</div><div><snip></div><div>Ign:242 <a href="http://ubuntu.mirror.neology.co.za/ubuntu">http://ubuntu.mirror.neology.co.za/ubuntu</a> xenial-security/multiverse DEP-11 64x64 Icons</div><div><font color="#ff00ff">Err:155 <a href="http://ubuntu.mirror.neology.co.za/ubuntu">http://ubuntu.mirror.neology.co.za/ubuntu</a> xenial/main Sources</font></div><div><font color="#ff00ff">  Cannot initiate the connection to ubuntu.mirror.neology.co.za:80 (2001:43e8:10:42::25). - connect (101: Network is unreachable) [IP: 2001:43e8:10:42::25 80]</font></div><div><snip></div><div>Reading package lists... Done</div><div>W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:49 and /etc/apt/sources.list.d/xenial-partner.list:4</div><div>W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:49 and /etc/apt/sources.list.d/xenial-partner.list:4</div><div><snip></div><div>E: Failed to fetch <a href="http://ubuntu.mirror.neology.co.za/ubuntu/dists/xenial-security/main/source/Sources">http://ubuntu.mirror.neology.co.za/ubuntu/dists/xenial-security/main/source/Sources</a>  Cannot initiate the connection to ubuntu.mirror.neology.co.za:80 (2001:43e8:10:42::25). - connect (101: Network is unreachable) [IP: 2001:43e8:10:42::25 80]</div><div>E: Some index files failed to download. They have been ignored, or old ones used instead.</div><div>W: Target Packages (partner/binary-amd64/Packages) is configured multiple times in /etc/apt/sources.list:49 and /etc/apt/sources.list.d/xenial-partner.list:4</div><div>W: Target Packages (partner/binary-i386/Packages) is configured multiple times in /etc/apt/sources.list:49 and /etc/apt/sources.list.d/xenial-partner.list:4</div><div><snip></div><div>******************************</div><div><span>-- <br>
  <meta http-equiv="Content-Type" content="text/html; CHARSET=UTF-8">
  <meta name="GENERATOR" content="GtkHTML/4.6.6">

<div>My preferred address is</div>
<a href="mailto:irons.charles@gmail.com">irons.charles@gmail.com</a><div>
Mobile   +2783 588 0028</div></span></div></body></html>