<html><head><meta http-equiv="Content-Type" content="text/html charset=windows-1252"></head><body style="word-wrap: break-word; -webkit-nbsp-mode: space; -webkit-line-break: after-white-space;">Hi all. Yesterday I have upgraded my bunt 13.10 server and everything  upgraded just fine accept for one thing. postgresql. Everything I do an upgrade or an install of something I get the following. "<span style="font-family: Menlo; font-size: 11px;">root@stuffage:~# apt-get upgrade</span><div style="margin: 0px; font-size: 11px; font-family: Menlo;">Reading package lists... Done</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">Building dependency tree       </div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">Reading state information... Done</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">1 not fully installed or removed.</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">After this operation, 0 B of additional disk space will be used.</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">Do you want to continue [Y/n]? yes</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">Setting up postgresql-9.1 (9.1.11-0ubuntu0.13.10) ...</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"> * Starting PostgreSQL 9.1 database server                                       <span style="color: rgb(195, 55, 32);">*</span> The PostgreSQL server failed to start. Please check the log output:</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">2013-12-13 05:53:29 MST FATAL:  private key file "server.key" has group or world access</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">2013-12-13 05:53:29 MST DETAIL:  File must be owned by the database user or root, must have no write permission for "group", and must have no permissions for "other".</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">                                                                         [<span style="color: rgb(195, 55, 32);">fail</span>]</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">invoke-rc.d: initscript postgresql, action "start" failed.</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">dpkg: error processing postgresql-9.1 (--configure):</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"> subprocess installed post-installation script returned error exit status 1</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">Errors were encountered while processing:</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;"> postgresql-9.1</div><div style="margin: 0px; font-size: 11px; font-family: Menlo;">E: Sub-process /usr/bin/dpkg returned an error code (1)Ē I have set the file permissions and tried doing ďapt-get purge postgresql" but nothing is resolved. I donít know what is going on here but I donít want to be getting that error every time I upgrade or install or remove software from my server. does anyone know how I could resolve this? thanks.</div><div><br></div><div>PS. I also did dpkg -r postgresql and all though it said that postgresql is fully removed, itís not when I do ďapt-get upgradeĒ.</div></body></html>