get-iplayer Snap

Paul Groves paul.groves.787 at gmail.com
Fri Mar 15 21:47:30 UTC 2019


Hi.

I have installed the snap as follows on Ubuntu 18.04.1 (with and without 
classic option).

sudo snap install get_player --classic

but when I try to use get_iplayer to download:
paul at paul-pc:~/Videos$ get_iplayer URL_HERE

I receive the following error:
ERROR: Cannot open (write): /var/lib/snapd/void/..........

I cannot find anything searching the web.

why is get_iplayer trying to write to this location? I want to save the 
file to the current directory ~/videos

I have also tried specifying --output "/home/paul/Vidoes"

and I have made the permissons of the videos folder 777

I tried the apt version but this is now missing and I cannot install it 
with: sudo apt install get-iplayer

how do I get get_iplayer to work now? Or how can I revert to the non 
snap version?

It seems every snap I try is broken:
Arduino cannot access serial ports
Audacity cannot access sound cards
and not get_iplayer cannot get from iplayer

Are these snaps production? Because they do not work on a clean install 
of 18.04.



More information about the ubuntu-users mailing list