Problem installing glom

John R. Sowden jsowden at americansentry.net
Mon Aug 20 04:24:46 UTC 2018


Thank for your response.  I copied the responses of the last 3 commands, 
shown beloe.  The are basically what I have received, expecially the 
last one.

-------------------------------------------



=============
sudo apt full-upgrade
The following packages have been kept back:
   gdb glom-utils libglom-1.30-0
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
john at sentry35:~$
========
sudo apt autoremove:
0 upgraded, 0 newly installed, 0 to remove and 3 not upgraded.
john at sentry35:~$
=============
sudo apt install glom:
john at sentry35:~$ sudo apt install glom
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  glom : Depends: libglom-1.30-0 (= 1.30.4-0ubuntu12) but 
1.30.1-0ubuntu1 is to be installed
         Depends: libpython3.6 (>= 3.6.0~b2) but it is not going to be 
installed
E: Unable to correct problems, you have held broken packages.
-------------------------------------------

On 08/19/2018 08:39 PM, Ralf Mardorf wrote:
> On Sun, 19 Aug 2018 18:26:54 -0700, John R. Sowden wrote:
>> I am running xubuntu v18.04.1 LTS.  When I try to install glom, using
>> apt install glom, I get errors indicating that there are brokemn
>> packages.
> sudo apt update
> sudo apt install --fix-broken
> sudo dpkg --configure --pending
> sudo apt autoremove
> sudo apt update
> sudo apt full-upgrade
> sudo apt autoremove
> sudo apt install glom
>
>
John




More information about the ubuntu-users mailing list