Anyone have issues with kernel 3.13.0-155-generic and java?

Guy Knights guy at bluebatgames.com
Wed Aug 15 18:21:53 UTC 2018


We have run into an issue this morning when upgrading some of our servers
to kernel 3.13.0-155-generic from 3.13.0-153-generic. After the upgrade,
the servers that had openjdk-jre (7 or 8, it doesn't seem to matter)
installed started rebooting before they managed to get to the login screen.
It's a little hard to be exactly sure where it was happening as these are
ec2 instances and you can't view the console in real time.

We started up new instances from the most recent AMI image that already has
kernel 3.13.0-155-generic installed, and they seemed fine until we ran our
ansible playbook, which worked until it got to the java install, where it
hung. We logged into the server console and tried running apt-get update
but it kept hanging when doing "setting up ca-certificates-java".

We did some further tests, upgrading the kernel on servers with the old
kernel and without java and then installing openjdk 7, and the install
failed part way through by hanging and then disconnecting the ssh session
somehow. On another server with the same config we installed openjdk 7
first then upgraded the kernel and it seemed to be ok, although this is the
only server that this worked on - for the servers that failed initially,
openjdk 7 was already installed when the kernel upgrade took place, and
these are the servers that keep rebooting.

In any case, we are now rolling back to an image with the older kernel and
will pin the kernel to this version to avoid upgrading it when we do our
weekly package updates until we can do further tests on an isolated
instance. However I was hoping someone here might have some insight into
this issue that can help us troubleshoot it. Any suggestions would be
appreciated.

Thanks,
Guy

-- 
<http://www.bluebatgames.com>
Guy Knights • Senior Systems Engineer
c: 778-996-2687p: 778-379-5120
<https://www.facebook.com/BlueBatGames/>
<https://www.linkedin.com/company/bluebat-games>
<https://twitter.com/BlueBatGames>  <http://www.bluebatgames.com>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20180815/16a5e5f6/attachment-0001.html>


More information about the ubuntu-users mailing list