Firefox update issue

MR ZenWiz mrzenwiz at gmail.com
Wed Feb 8 19:23:53 UTC 2017


On Wed, Feb 8, 2017 at 3:44 AM, Colin Law <clanlaw at gmail.com> wrote:
> On 8 February 2017 at 00:52, MR ZenWiz <mrzenwiz at gmail.com> wrote:
>>
>> There is no lsb_release package and I'm not sure which package it's in
>
> Odd the way
> sudo apt-cache show lsb-release
> worked for you if there is no such package.
> Hint, the devil is in the detail :)
>

True, but I actually looked for lsb_release (not lsb-release).

However:

admar at marbase:~/Downloads $ sudo apt-get install --reinstall lsb-release
Reading package lists... Done
Building dependency tree
Reading state information... Done
0 upgraded, 0 newly installed, 1 reinstalled, 0 to remove and 0 not upgraded.
Need to get 11.8 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu xenial-updates/main amd64
lsb-release all 9.20160110ubuntu0.2 [11.8 kB]
Fetched 11.8 kB in 0s (25.7 kB/s)
(Reading database ... 259036 files and directories currently installed.)
Preparing to unpack .../lsb-release_9.20160110ubuntu0.2_all.deb ...
Unpacking lsb-release (9.20160110ubuntu0.2) over (9.20160110ubuntu0.2) ...
Processing triggers for man-db (2.7.5-1) ...
Setting up lsb-release (9.20160110ubuntu0.2) ...
admar at marbase:~/Downloads $ lsb_release
No LSB modules are available.

And then:

admar at marbase:~/Downloads $ sudo apt-get install --reinstall
`apt-cache pkgnames | grep lsb`
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  alien at debugedit libjpeg62 librpm3 librpmbuild3 librpmio3
librpmsign3 pax rpm rpm-common rpm2cpio s-nail
Suggested packages:
  rpm-i18n elfutils rpmlint rpm2html
The following NEW packages will be installed:
  alien at debugedit libjpeg62 liblist-utilsby-perl librpm3
librpmbuild3 librpmio3 librpmsign3 lsb lsb-core
  lsb-invalid-mta lsb-printing lsb-security pax rpm rpm-common rpm2cpio s-nail
0 upgraded, 19 newly installed, 2 reinstalled, 0 to remove and 0 not upgraded.
Need to get 1,111 kB/1,123 kB of archives.
After this operation, 3,446 kB of additional disk space will be used.
Do you want to continue? [Y/n] y
:
Setting up alien (8.95) ...
Setting up at (3.1.18-2ubuntu1) ...
insserv: warning: script 'lprng' missing LSB tags and overrides
<<<<< interesting stuff here
insserv: warning: script 'cupsys' missing LSB tags and overrides
insserv: warning: script 'lpd' missing LSB tags and overrides
Setting up liblist-utilsby-perl (0.10-1) ...
Setting up pax (1:20151013-1) ...
Setting up s-nail (14.8.6-1) ...
update-alternatives: using /usr/bin/s-nail to provide /usr/bin/mailx
(mailx) in auto mode
Setting up lsb-invalid-mta (9.20160110ubuntu0.2) ...
Setting up lsb-security (9.20160110ubuntu0.2) ...
Setting up lsb-core (9.20160110ubuntu0.2) ...
Setting up lsb-printing (9.20160110ubuntu0.2) ...
Setting up lsb (9.20160110ubuntu0.2) ...
Processing triggers for libc-bin (2.23-0ubuntu5) ...
Processing triggers for systemd (229-4ubuntu16) ...
Processing triggers for ureadahead (0.100.0-19) ...
admar at marbase:~/Downloads $ lsb_release
LSB Version: core-9.20160110ubuntu0.2-amd64:core-9.20160110ubuntu0.2-noarch:printing-9.20160110ubuntu0.2-amd64:printing-9.20160110ubuntu0.2-noarch:security-9.20160110ubuntu0.2-amd64:security-9.20160110ubuntu0.2-noarch
admar at marbase:~/Downloads $

So that now works, but I'm not sure how that applies to my FF install,
which is up and running (though it won't play embedded MP3 links).  I
reinstalled FF after the above and it still won't play the links.  I
have to use Chrome for this.

Probably not a suitable topic for this list....

Thanks.
MR



More information about the ubuntu-users mailing list