noauto option ignored in /etc/fstab?

Tom H tomh0665 at gmail.com
Mon Dec 4 18:12:07 UTC 2017


On Mon, Dec 4, 2017 at 12:20 PM, Tom H <tomh0665 at gmail.com> wrote:
> On Mon, Dec 4, 2017 at 11:13 AM, Josef Wolf <jw at raven.inka.de> wrote:
>> On Fri, Dec 01, 2017 at 10:14:18AM -0500, Tom H wrote:
>>> On Fri, Dec 1, 2017 at 5:36 AM, Josef Wolf <jw at raven.inka.de> wrote:
>>>> On Fri, Dec 01, 2017 at 05:12:58AM -0500, Tom H wrote:
>>>>> On Fri, Dec 1, 2017 at 2:50 AM, Josef Wolf <jw at raven.inka.de> wrote:
>>>>>>
>>>>>> I have the following line in /etc/fstab:
>>>>>>
>>>>>> UUID=XXXX-XXXX-XXXX-XXXX /boot ext4 noauto,relatime 0 2
>>>>>>
>>>>>> The noauto option should prevent the fs to be mounted during boot.
>>>>>>
>>>>>> That worked great in every distro I have touched in the last 20 years.
>>>>>>
>>>>>> But since I reinstalled this box with 16.04 LTS, this FS is mounted
>>>>>> during boot.
>>>>>>
>>>>>> Any ideas what causes this FS to be mounted during boot?
>>>>>
>>>>> Is this an EFI system?
>>>>>
>>>>> If it is, you'll have to set "/boot/efi" as "noauto" too.
>>>>
>>>> Before the reinstall, I had 14.04 with EFI and everything worked fine.
>>>>
>>>> The the disk failed. I reinstalled 16.04 WITHOUT EFI.
>>>>
>>>> Thus, no. There's no /boot/efi anymore on this system.
>>>
>>> Here's the output from my laptop before and after adding "noauto" to
>>> the "/boot" line in "/etc/fstab" ("/boot" is my EFI partition). It
>>> works. You must have misconfigured something or hit a bug.
>>
>> Well, it might work for you, but it doesn't work for me...
>
> We know. I was simply pointing out that it's not broken for everyone.
>
>> So, how do I find out what's the cause?
>
> What does systemd think your mount is? What's the output of "cat
> /run/systemd/generator/boot.mount"?

This seems to be a systemd bug.

I set up a BIOS VM and "cat /run/systemd/generator/boot.mount" doesn't
help. I expected "noauto" not to have "Before=local-fs.target" but my
laptop has it too.

root at jwolf:~# egrep -v '^$|^#' /run/systemd/generator/boot.mount
[Unit]
SourcePath=/etc/fstab
Documentation=man:fstab(5) man:systemd-fstab-generator(8)
Before=local-fs.target
Requires=systemd-fsck at dev-disk-by\x2duuid-7657da8f\x2d9398\x2d4171\x2db298\x2d5415bffbe22a.service
After=systemd-fsck at dev-disk-by\x2duuid-7657da8f\x2d9398\x2d4171\x2db298\x2d5415bffbe22a.service
[Mount]
Where=/boot
What=/dev/disk/by-uuid/7657da8f-9398-4171-b298-5415bffbe22a
Type=ext4
Options=noauto
root at jwolf:~#



More information about the ubuntu-users mailing list