apt not upgrading package

Colin Law clanlaw at gmail.com
Sun Jun 5 07:13:26 UTC 2016


On 5 June 2016 at 06:32, Nils Kassube <kassube at gmx.net> wrote:
> Colin Law wrote:
>> I have added a ppa for mosquitto, when I run
>> sudo apt-get update && sudo apt-get dist-upgrade
>> it says:
>> 0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.
>> but apt-cache policy for mosquitto shows:
>> $ apt-cache policy mosquitto
>> mosquitto:
>>   Installed: 1.4.8-1build1
>>   Candidate: 1.4.9-0mosquitto1
>>   Version table:
>>      1.4.9-0mosquitto1 500
>>         500
>> http://ppa.launchpad.net/mosquitto-dev/mosquitto-ppa/ubuntu
>> xenial/main amd64 Packages
>>  *** 1.4.8-1build1 500
>>         500 http://gb.archive.ubuntu.com/ubuntu xenial/universe amd64
>> Packages 100 /var/lib/dpkg/status
>>
>> Which says there is a candidate for update.  I cannot see why apt-get
>> does not offer the upgrade.  If mosquitto were held then I think
>> apt-get would show it as held back.  Any suggestions as to what is
>> going on?
>
> Could it be that one of the dependencies for the new version is missing?

I see the cause now, I tried
sudo apt-get -s install mosquitto
and got
The following packages have unmet dependencies.
 mosquitto : Depends: libwebsockets3 (>= 1.2) but it is not installable

So now I can investigate why.
It is not very clever of apt-get to not give any indication that there
is a problem with the upgrade.  I also tried
sudo apt upgrade && sudo apt full-upgrade
and in this case the upgrade said that there is an upgradable package,
though the full-upgrade still did not give any indication of problems.
However at least there is some advantage to using apt rather than
apt-get.

Thanks

Colin



More information about the ubuntu-users mailing list