Customize alternate install CD with UEFI?

Josef Wolf jw at raven.inka.de
Fri Jul 22 06:13:11 UTC 2016


On Thu, Jul 21, 2016 at 03:27:18PM +0200, Josef Wolf wrote:
> On Thu, Jul 21, 2016 at 02:53:53PM +0200, Liam Proven wrote:
> > On 20 July 2016 at 22:58, Josef Wolf <jw at raven.inka.de> wrote:
> > > Will the d-i partitioner properly shrink the partition? Or will I need to
> > > defragment the disk before shrinking it?
> > 
> > I am not sure what "the d-i partitioner" means.
> > 
> > GParted on the boot/install DVD image should do, yes.
> 
> AFAIK, with the (Live-)DVD, it is not possible to do a full automated
> preseeded install.

Yesterday, I gave the installer on the live-DVD a try, and was somewhat
disappointed:

My plan was:
1. Shrink C:
2. Delete D:
3. Move the rescue disks, to get a big concatenated chunk of free room
4. separate /boot (300m)
5. encrypted LVM to hold /, swap and /data

I'm doing this scheme for many years with no problems.

- Resizing worked, but to move the rescue partitions, I had to reboot into the
  live-system and use gparted.
- Creating a big "physical volume for encrypted data" worked fine. But it can
  hold only one partition? So I decided to delete it and create three
  "physical volumes for encrypted data", one for /, one for swap and one for
  /data. BUT: now way: once created, there's no way to delete this big crypted
  volume that I created before. Boot into the live system again to delete it.
- Third attempt:
  1. create crypted volume for root, partitioner shows me three additional
     entries: one at the original place, one at the very top, and one appended
     with "crypt". I create / within the entry appended with "crypt"
  2. create crypted volume for swap, same procedure as in (1.)
  3. create crypted volume for data: The two additional entries won't
     appear. How that?
  4. Now I'm getting a warning that a non-crypted swap was found. I
     double-checked three times: swap is within the crypted volume an no other
     swap exists.

At that point I stopped using the live-installer and went back to the
alternate/server-CD, which worked fine.

-- 
Josef Wolf
jw at raven.inka.de



More information about the ubuntu-users mailing list