cannot file a bug report...

Peter Silva peter at bsqt.homeip.net
Mon Jul 18 18:30:42 UTC 2016


On Mon, Jul 18, 2016 at 11:48 AM, Colin Law <clanlaw at gmail.com> wrote:
> On 18 July 2016 at 16:32, Peter Silva <peter at bsqt.homeip.net> wrote:
>> Just discovered my ethernet card (which is disconnected) consumes
>> 19 watts on my laptop.  when I do sudo rmmod r8168 after about ten
>> minutes the laptop is completely cool, normal consumption is something
>> like 11W for the whole machine now (was 24W before.)   Checked through
>> the db and it does not appear to be an existing bug.
>>
>> ubuntu-bug r8168-dkms
>>
>> It starts gathering information, then opens a blank window in chrome.
>> that's all.  never get to the bug entry form.
>
> Do you get the "Send problem report to the developers" popup?
>

yes.

> Which ubuntu version are you using?
>

16.04

> Are you sure it is not a broken card?

It works fine when ethernet is connected... how would I diagnose that?


> When it is running hot do 'top' or system monitory show that there is
> high processor usage?
>

nope nada.  system monitor when sorted by cpu usage shows the top user
using 1% of a cpu.   top shows chrome using more than that, but the
load average is still extremely low.

powertop sample:

Summary: 1452.9 wakeups/second,  170.8 GPU ops/seconds, 0.0 VFS
ops/sec and 24.9% CPU use

Power est.              Usage       Events/s    Category       Description
  14.8 W      0.0 pkts/s                Device         Network
interface: eth0 (r8168)
  2.28 W     75.5 ms/s     338.6        Process        compiz
  2.13 W     74.4 ms/s     216.8        Process        /opt/google/chrome/chrome
  614 mW      2.1 ms/s     157.9        Timer          tick_sched_timer
  554 mW     11.4 ms/s      94.3        Process
/usr/lib/xorg/Xorg -core :0 -seat s
  503 mW      3.8 ms/s     121.5        Process
/usr/lib/x86_64-linux-gnu/notify-os
  392 mW      7.2 ms/s      70.7        Interrupt      [34] i915
  340 mW      2.5 ms/s      80.7        Interrupt      [4] block(softirq)
  325 mW    514.3 µs/s      86.9        kWork          intel_unpin_work_fn

top (a few seconds later:)

Tasks: 283 total,   1 running, 282 sleeping,   0 stopped,   0 zombie
%Cpu(s):  0.3 us,  0.1 sy,  0.0 ni, 98.9 id,  0.6 wa,  0.0 hi,  0.0 si,  0.0 st
KiB Mem : 11733404 total,  8200876 free,  1839840 used,  1692688 buff/cache
KiB Swap: 24761340 total, 24761340 free,        0 used.  9018464 avail Mem

  PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
 3311 root      20   0  861052 112568 100632 S   2.0  1.0   0:04.48 Xorg
 4982 peter     20   0 1385520 263568  67708 S   1.3  2.2   0:10.33 chrome
 4404 peter     20   0  664300  38640  29068 S   1.0  0.3   0:01.14 gnome-term+
 2649 root      20   0       0      0      0 S   0.3  0.0   0:00.03 jbd2/sda9-8
 4561 peter     20   0   46020   3808   3084 R   0.3  0.0   0:00.24 top
    1 root      20   0  119800   5928   3944 S   0.0  0.1   0:01.00 systemd
    2 root      20   0       0      0      0 S   0.0  0.0   0:00.00 kthreadd


then I do

sudo rmmod 8168

and powertop shows baseline power estimated drops from 23W to 4.7W,
over about a minute.  It fluctuates lower, to under 3W.

So it is pretty dramatic and obvious.


> Colin
>
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users



More information about the ubuntu-users mailing list