proprietary nvidia drivers broken since 16.04

Peter Silva peter at bsqt.homeip.net
Sat Jul 2 16:50:52 UTC 2016


When I sent the letter the situation was:
vanilla ubuntu (yes, lightdm, and latest stock kernel 4.4.0-30, also
have broadcom-sta drivers for wireless, and r8168 for ethernet) and
stock repos (no ppa's, and no nvidia scripts used.)
After sending the first letter, I tried:

sudo apt-get install nvidia-prime
sudo prime-select intel
reboot

And then the situation was improved as follows:   It now boots into
the normal gui environment.  I can see the driver is installed in the
Additional Drivers' dialog, but
as far as I can tell, it is actually using the intel gpu anyways.   I
can go into the nvidia-settings
tool and select 'NVIDIA (Performance Mode)' from the PRIME Profiles,
and then logout.
but when I log int, just as before, I get a blank screen.  It is still
better though, because
I can switch to terminal mode, run prime-select intel, and all is well
(but no nvidia accelleration.)

With that, I then tried the advice here:

https://devtalk.nvidia.com/default/topic/946180/linux/ubuntu-how-to-use-nvidia-drivers-/
...
which boils down to:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt-get update
sudo apt-get install nvidia-367 nvidia-settings

retried the same experiments, and the result is the same...



Advice about who to submit a bug report to would be helpful:
I cannot figure out who to submit bug reports to... ubuntu says they
don't support proprietary drivers, but I want to use standard tools
(apt-get) not some vendor script that will break at every kernel
upgrade.


On Sat, Jul 2, 2016 at 12:30 PM, Ralf Mardorf <silver.bullet at zoho.com> wrote:
> PS: Are there any NVIDIA log files in /var/log?
>
>
> --
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users



More information about the ubuntu-users mailing list