16.04: issues with wireless on MacBook Pro

Nils Kassube kassube at gmx.net
Fri Jul 1 05:28:08 UTC 2016


Paul Smith wrote:
> For the most part everything works great, but there is one major
> issue: the wireless.  As you may know this hardware uses a Broadcom
> wireless card: mine is Broadcom Corporation BCM4331 802.11a/b/g/n
> (rev 02) FWIW.
> 
> My wireless actually works fine... for a short while.  Every 2-3
> minutes or so, though, it seems to lose connection and, depending on
> what I'm doing at the time, I'll either get an error that the hostname
> cannot be resolved, or the host is not responding, or maybe it's just
> slow but eventually succeeds.  I've tried setting my DNS server to
> 8.8.8.8 but that didn't solve the problem.
> 
> The network comes back alive and my ssh sessions, VPN session, etc.
> are not dropped, but nevertheless a network hang for 5-20s every few
> minutes is not acceptable.

> If I run iwevent I can see a message "Scan request completed" exactly
> every 2 minutes.  I don't know if that's normal or not.  No other
> messages are shown.  dmesg shows no messages since I booted.

That looks to me like network manager scans for other networks every two 
minutes. As you have an a/b/g/n wireless card, it will scan all 
available channels on the 2 GHz and on the 5 GHz bands which takes quite 
some time. On my machine with an a/b/g/n card a scan takes ~14 seconds 
with only 4 access points visible. And during this time it doesn't 
transfer the data you're intersted in.

That was the reason why I abandoned network manager many years ago - 
especially video chat with ekiga was unacceptable with regular sound 
drops. Since then I use wicd on all machines and never had such a 
problem again. If you want to try wicd, don't forget to remove the 
network manager packages because otherwise network manager and wicd 
would fight to control the wireless device and none of them wins, i.e. 
nothing works.


Nils




More information about the ubuntu-users mailing list