How to set the single click speed? [SOLVED]

Tommy Trussell tommy.trussell at
Fri Jan 22 18:05:20 UTC 2016

On Thu, Jan 21, 2016 at 7:28 PM, Jim Byrnes <jf_byrnes at> wrote:

> On 01/19/2016 06:26 PM, Tommy Trussell wrote:
>> On Tue, Jan 19, 2016 at 5:18 PM, Jim Byrnes <jf_byrnes at>
>> wrote:
>>> This is a fairly new HP desktop that when running 12.04 did not have this
>>> problem.
>>> Also, have you tried a different mouse?
>>> No. I said mouse for simplicity sake. It is a Kensington Expert Mouse (ie
>>> trackball), but when I boot to 12.04 it works without a problem.
>> You might try installing this package
>> gpointing-device-settings
>> and use that tool, which is called pointing-devices. It "exposes" more of
>> the settings than the simplified Mouse control. If it works for you, I
>> suggest putting it on the launcher so you can pull it up easily. If the
>> settings don't "stick" you can move it high on the launcher to make it
>> easily accessible via the keyboard.
>> If you do some Internet searches for "Kensington Expert Mouse Ubuntu
>> 14.04"
>> you'll see some tips involving hand-editing various X settings so you can
>> use all the buttons. So presumably others have used them successfully!
>> Be sure to report back to the list when you figure out the answer, to help
>> the next person who comes along.
> Tommy,
> Got so busy trying to solve this I almost didn't back to your pointing
> device advice. Glad I did because it seems to have fixed it.
> It brought up a little gui expert mouse window that was all greyed out.
> Once I clicked on middle button and wheel emulation I set timeout and
> inertia from short to long and that seemed to solve the problem, but it did
> not survive a reboot.  I opened the window again and deactivated the
> emulations but left the other settings on long. I rebooted and the menus
> function normally.
> Clicking on them is not quite like it was under 12.04, but it is so close
> that I am sure I will get used to it.
> Thanks,  Jim

Thank you for the follow up! I was thinking of reminding you of my
suggestion, but decided to let the discussion play out, assuming you might
have tried it and it didn't help.

The reason I though of it is about a year ago I bought this Lenovo ThinkPad
E540 with a bizarre trackpad, and its default behavior under Ubuntu was
completely unacceptable. Very similar to what you and others were
describing, plus other annoying behaviors.

I found that just installing and using gpointing-device-settings did
something (updated some firmware in the device, maybe?) and I have never
had to do another thing to it. I can even boot other linuxes without using
the utility. (I never tried any version of Windows except to make sure it
booted, and now that drive is in storage in case the SSD fails.)

I know if you search around you will see others complaining that
gpointing-device-settings settings don't persist in some situations, and I
don't know if there's a single workaround, but you can probably coax Ubuntu
to open it when you log in.

You might also try booting into some variety of KDE (Kubuntu etc.) to see
if its pointing tools can do a better job with your trackball; you might
decide you like it better.

P.S.: Maybe one of these days I will dig out my ancient Kensington
trackball and play with some of the ways folks have published to connect it
to a modern linux box. It's a Macintosh ADB model, and as nice as it is I
don't care as much about it as my old (also ADB) Apple Extended Keyboard.
It's the gigantic one, nicknamed Saratoga, after the aircraft carrier, and
it has every button you might want, and excellent feel. Well, it did 20
years ago. ;-)
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <>

More information about the ubuntu-users mailing list