UEFI wakealarm

Juan Blanco intuitionist at msn.com
Sat Jan 9 19:49:23 UTC 2016

Hello blind Pete,

Excuse me for the first things first solution at the beginning.  Have you tried booting in Recovery mode, and select Check all file systems installed?  

This Ubuntu feature has helped out of many different puzzles.


Juan L. Blanco

> To: ubuntu-users at lists.ubuntu.com
> From: 0123peter at gmail.com
> Subject: UEFI wakealarm
> Date: Sat, 9 Jan 2016 18:18:45 +1100
> Hi *, 
> I tried posting this in nntp://alt.os.linux.ubuntu, but I did not 
> get much joy, so I am trying here.  
> This might be a kernel problem, an Ubuntu problem, a firmware problem, 
> a MythTV problem, or a whole bunch of problems.  My Mythbuntu 14.04 LTS 
> does not go to sleep and wake itself up like I want it to.  What I want 
> to find out is, which of the following are real bugs and who should they 
> be reported to?  
> The UEFI firmware has the real time clock set to UTC.  When it was 
> configured to wake at a particular time of day, it worked as expected.  
> It is now configured to wake "by OS", that sometimes works.  
> There is a file /etc/init/hwclock.conf that never seems to get executed.  
> I've added commands to echo information to a log file, but nothing 
> appears in the log file.  That file, hwclock.conf, still exists in Xenial.  
> There is a file /etc/init/hwclock-save.conf that does get executed, 
> but only to the line that starts with "exec".  Log entries appear up to 
> that line but not after.  Deleting the "exec" and calling "hwclock" 
> directly seems to work; stuff gets logged before and after that line 
> and sometimes the wake alarm works.  
> Sometimes "cat /sys/class/rtc/rtc0/wakealarm" agrees with 
> "cat proc/driver/rtc" (allowing for timezones), but often the 
> wakealarm is empty.  
> Usually, "date -d +10min +%s > /sys/class/rtc/rtc0/wakealarm" 
> as root works, but not always.  The wakealarm can remain empty.  
> Plus a lot of things that seem to be MythTV specific, but I will ask 
> elsewhere about those.  
> -- 
> blind Pete
> Sig goes here...  
> -- 
> ubuntu-users mailing list
> ubuntu-users at lists.ubuntu.com
> Modify settings or unsubscribe at: https://lists.ubuntu.com/mailman/listinfo/ubuntu-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20160109/42b1d18e/attachment.html>

More information about the ubuntu-users mailing list