generic ISO-to-bootable-USB creator?

Karl Auer kauer at biplane.com.au
Fri Sep 11 05:02:51 UTC 2015


I've googled around, but reports are conflicting.

Is it possible, and if so how, to create a bootable USB drive in Linux
from a random (bootable) ISO? To my shame (or possibly my credit?) I
have never in my life created a bootable disk for any operating system
other than Linux! In this case however, the ISO concerned is actually a
Linux ISO (generated by EaseUS), but I still can't make a bootable disk
from it.

I tried just using dd to blat the image straight onto the drive; didn't
work. There was a file system on the drive, and I could mount it OK, it
was readable/writable etc and it contained the expected files, even
though there were no partitions on the drive. But it would not boot. I
also tried with a WinPE image (also generated by EaseUS) but that also
failed the same way - OK to mount, can see the right files, but not
bootable. And BTW also not writable! Look what happened after I did this
and mounted the newly-written partitionless USB drive:

kauer at karl:~$ sudo mount /dev/sdb /mnt
mount: block device /dev/sdb is write-protected, mounting read-only

Kinda interesting given our recent discussion abour read-only drives.
would love to know how it got marked read-only!

I expected the startup disk creator to be able to use at least the Linux
ISO image, but no. It would not let me select the ISO as a source (and
gave no visible indication why not, which I think is poor form in any
program).

The Nautilus "Write to disk" option wouldn't show the inserted USB drive
as a suitable target and just said "no disk available". Maybe it's only
good for CD and DVD.

unetbootin is recommended all over the place, but lots of people say it
is for Linux images only, and other people say it is incompatible with
Debian (and therefore with Ubuntu), though I think this just means when
using Debian images:

   https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=775689

... so I think I will try unetbootin as well.

It could be of course that the images are not actually bootable - but
for an emergency rescue disk that doesn't make a lot of sense. I have
yet to try the Easeus tool to make the USB drive itself, but even if
that works it's a bit sad not to be able to do it in Linux.

Regards, K,

-- 
~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
Karl Auer (kauer at biplane.com.au)
http://www.biplane.com.au/kauer
http://twitter.com/kauer389

GPG fingerprint: 3C41 82BE A9E7 99A1 B931 5AE7 7638 0147 2C3C 2AC4
Old fingerprint: EC67 61E2 C2F6 EB55 884B E129 072B 0AF0 72AA 9882





More information about the ubuntu-users mailing list