What is the currently accepted means of getting Nvidia to work on Ubuntu 15.04?

Alex Eftimiades alexeftimiades at gmail.com
Sat May 30 03:33:54 UTC 2015


I've seen and followed at least 8 guides to getting Nvidia's proprietary 
drivers working with Ubuntu.

Here are a list of answers and guides that I have tried (about twice 
each) that *do not work*.

  * http://askubuntu.com/questions/47292...setup-in-14-04
    <http://askubuntu.com/questions/472928/correct-nvidiaintel-graphics-setup-in-14-04>
    That fixed the GLX error, but I'm clearly watching movies on my CPU.
    The CPU monitor goes through the roof and the video takes a while to
    skip around. Also, "glxspheres not found" is what I get when I try
    the "glxspheres" command. So I guess it "fixes the error" in the
    sense that it disables the graphics card and leaves a bunch of
    software that appear to cancel each other out on my system.
  * https://help.ubuntu.com/community/Bi...erHowto/Nvidia
    <https://help.ubuntu.com/community/BinaryDriverHowto/Nvidia> This
    leads to the screen randomly freezing. Oddly enough, I appear to
    never technically loose control of the keyboard and mouse. It's just
    that the screen randomly decides to stop updating. Upon switching
    the screen off and on, I've found that my futile efforts to move the
    mouse and type on the keyboard did do something, it was just that
    the screen stopped updating. That said, I retried this approach
    again today (with both the "tested" and "updated" drivers) and it
    appeared to just lead to "GLX not found" errors every time I try to
    open parole.
  * http://askubuntu.com/questions/45122...-nvidia-driver
    <http://askubuntu.com/questions/451221/ubuntu-14-04-install-nvidia-driver>
    I tried installing the packages from apt-get, but it just repeatedly
    tells me to configure xorg. No matter how many times I run
    nvidia-xconfig and/or reboot, this problem persists.
  * http://www.binarytides.com/install-n...-ubuntu-14-04/
    <http://www.binarytides.com/install-nvidia-drivers-ubuntu-14-04/>
    The xorg-edgers ppa has proved to have the same effect as the
    "additional drivers" approach on the official guide in that it just
    leads to the screen randomly not updating. This approach however,
    has left my system a mess when when I try to get rid of the drivers
    it installs. A lot of stuff gets upgraded when adding the
    xorg-edgers repository and it becomes a nightmare to bring the
    system back. I retried this approach today as well (I basically
    spent the last 6 hours trying everything I tried about 6 months ago
    hoping that the drivers had been updated to actually work), and this
    does not cause the screen to randomly stop updating anymore. Rather,
    like the "additional drivers" method, it just gives me a "GLX not
    found" error every time I try to open parole.
  * http://askubuntu.com/questions/48141...nstead-nouveau
    <http://askubuntu.com/questions/481414/install-nvidia-driver-instead-nouveau>
    As nearest I can tell the blacklist step does exactly nothing except
    create a new text file in an obscure directory. But I did check it
    off my list of things to try.
  * http://askubuntu.com/questions/14920...all-nvidia-run
    <http://askubuntu.com/questions/149206/how-to-install-nvidia-run>
    I've tried the "use the run file from nvidia's official website"
    approach several times over the course of a year now. As of about 6
    months ago, it used to produce that annoying screen freezing
    problem. As of today, it just gives me the old "GLX not found" error.
  * http://ubuntuforums.org/showthread.php?t=1741783 Installing mesa
    packages does not get rid of the "GLX not found" even though the
    packages does contain the phrase "GLX".
  * Install dkms. I can't find the askubuntu answer that involved
    apt-get install dkms, but that does not produce any noticeable
    effect either.


So after compiling this series of dead ends, I was hoping someone might 
be able to either tell me of a new means of getting my graphics card to 
work, or confirm that there is no known solution to this problem.

Obviously, I would be thrilled if someone knows of a "tried and true" 
way to do it. I am admittedly frustrated by all of these lengthy 
proposed fixes that never solve the problem--then having to try to 
"undo" each failed installation before trying the next approach.

I am currently typing this question on an ASUS laptop that, according to 
the sticker under my left wrist, says it contains a "Nvidia Geforce GTX 
960M" graphics card.

Another possibility is that I actually had installed the graphics cards 
at some point, and I misdiagnosed slow rendering for an insufficient 
graphics card (I sometimes render 3D volumetric data with mayavi) for 
ill configured graphics drivers. Though I strongly doubt that was the 
case since I have always confirmed the CPU work monitor always 
skyrocketed as I attempted to rotate the 3D image or even play a movie. 
Also, my nvidia settings manager has never actually confirmed a working 
graphics card--often complaining about an ill-configured xorg settings 
("We're sorry, the graphics card you are trying to reach is not 
available, please run nvidia-xconfig and try again") or failing to exist 
entirely (then I install it, and it resumes complaining about incorrect 
xorg settings).

~Alex Eftimiades
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20150529/3f610566/attachment-0001.html>


More information about the ubuntu-users mailing list