kate: the fish protocoll is not supported anymore

robert rottermann robert at redcor.ch
Wed May 13 06:54:03 UTC 2015

On 13.05.2015 08:29, Petter Adsen wrote:
> On Wed, 13 May 2015 08:21:49 +0200
> robert rottermann <robert at redcor.ch> wrote:
>> On 13.05.2015 07:52, Nils Kassube wrote:
>>> robert rottermann wrote:
>>>> On 12.05.2015 18:27, Nils Kassube wrote:
>>>>> robert at redcor.ch wrote:
>>>>>> it looks as if the fish protocol is not working anymore with the
>>>>>> kate
>>>>>> version that is installed together with ubuntu 15.04.
>>>>> It works if you use Kubuntu - kate alone doesn't include all
>>>>> dependencies needed to use fish.
>>>>>> Is there a module to load to have it working?
>>>>>> Without it kate becomes rather unusable for me.
>>>>> It looks like you need these packages (including dependencies):
>>>>> plasma-workspace kdelibs5-plugins kde-runtime kdeconnect kio
>>>>> kio-extras kinit
>>>> unfortunately this is not yet enough.
>>>> the attempt to open a file:
>>>>        fish://root@localhost/etc
>>>> produces:
>>>> etc
>>>> File not found.
>>>> Please verify the correct file name was given
>>> Hmm, that looks a bit fishy. Actually I had only tried it with an
>>> existing file on a remote machine. I have no idea what should
>>> happen if I try to open a directory. As there is no root login
>>> allowed on my machines, I tried running
>>> kate fish://nils@someremotehost.lan/home/nils/bin
>>> which produces a similar error message (the directory ~/bin does
>>> exist on that machine), And that test was done with Kubuntu 14.04
>>> on both machines. Opening an existing file worked though, like it
>>> worked on the Xubuntu 15.04 machine where I added the packages
>>> mentioned above.
>>> Maybe you could try to open an existing file?
>> fish://root@localhost/etc/hosts
>> produced the same error
> Are you sure sshd allows root logins? It sounds a little like maybe
> there is something wrong with your setup.
yes, I can
to be sure I checked with a linux box where I login using my public key.
It failed also

and even trying to open a local file in my home directory:


     File not found.

Please verify the correct file name was given.

on my laptop I even installed kubuntu, and I have the same problem.


-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://lists.ubuntu.com/archives/ubuntu-users/attachments/20150513/648990e7/attachment.html>

More information about the ubuntu-users mailing list