kate: the fish protocoll is not supported anymore

Nils Kassube kassube at gmx.net
Wed May 13 05:52:52 UTC 2015


robert rottermann wrote:
> On 12.05.2015 18:27, Nils Kassube wrote:
> > robert at redcor.ch wrote:
> >> it looks as if the fish protocol is not working anymore with the
> >> kate
> >> version that is installed together with ubuntu 15.04.
> > 
> > It works if you use Kubuntu - kate alone doesn't include all
> > dependencies needed to use fish.
> > 
> >> Is there a module to load to have it working?
> >> Without it kate becomes rather unusable for me.
> > 
> > It looks like you need these packages (including dependencies):
> > plasma-workspace kdelibs5-plugins kde-runtime kdeconnect kio
> > kio-extras kinit
> 
> unfortunately this is not yet enough.
> 
> the attempt to open a file:
>      fish://root@localhost/etc
> 
> produces:
> 
> etc
> 
> File not found.
> 
> Please verify the correct file name was given

Hmm, that looks a bit fishy. Actually I had only tried it with an 
existing file on a remote machine. I have no idea what should happen if 
I try to open a directory. As there is no root login allowed on my 
machines, I tried running

kate fish://nils@someremotehost.lan/home/nils/bin

which produces a similar error message (the directory ~/bin does exist 
on that machine), And that test was done with Kubuntu 14.04 on both 
machines. Opening an existing file worked though, like it worked on the 
Xubuntu 15.04 machine where I added the packages mentioned above.

Maybe you could try to open an existing file?


Nils




More information about the ubuntu-users mailing list