How to try fglrx driver

Petter Adsen petter at synth.no
Sat Jan 31 08:06:58 UTC 2015


On Fri, 30 Jan 2015 14:32:49 -0600
Linda <haniganwork at earthlink.net> wrote:

> I am having trouble getting teamviewer to start at boot and 
> from reading the logs and doing some searches it sounds like 
> it is a video/x windows issue.
> The machine has integrated graphics and shows it is the ATI 
> Radeon Xpress 200  which from what I can find can use the 
> fglrx driver.
> I downloaded the fglrx package with synaptic
> My problem is that software updater does not give me any 
> choices under additional drivers. Can someone point me in 
> the right direction on how to try the fglrx driver to see if 
> it solves the issue?
>                Thank you
>                    Linda
> 

You can find the latest Catalyst drivers for Ubuntu at:

http://support.amd.com/en-us/download/desktop?os=Ubuntu+x86+64

If you need 32-bit drivers, replace "64" with "32" in the above link.

Note: These packages are for 14.04 and 12.04, if you want them for 14.10
I believe you have to do a manual install (but I haven't tried).

Download the ones you need (you will need at least the drivers
themselves, and probably the control center), then install with "dpkg -i
fglrx*" in the directory you downloaded them into.

You might want to do some searches and read up on the process of
installing them first, as there may be additional things you need to do.
Start here:

http://wiki.cchtml.com/index.php/Main_Page

Especially read this:

http://wiki.cchtml.com/index.php/Ubuntu_Trusty_Installation_Guide

(if you run 14.04, that is, but most of this information should retain
to 14.10, I guess - haven't tried)

Then you're on your own :) Be careful, messing with these drivers are
an excellent way to hose X :) I advice you to have a good, long look at
the last link I mentioned, and ask if there's something you're unsure
about. If you already are running with fglrx drivers and not the radeon
driver, then it would probably just be a simple case of upgrading.

Good luck :)

Petter



More information about the ubuntu-users mailing list