Gedit - disabling "untitled document 1"

Nils Kassube kassube at gmx.net
Thu Jan 29 09:53:01 UTC 2015


rikona wrote:
> Wednesday, January 28, 2015, 10:33:59 PM, Karl wrote:
> > Please describe in excruciating detail exactly how you are starting
> > gedit.
> 
> Mostly, I right-click on a file in konq and select "Open with gedit".

I suppose with "konq" you probably mean "konqueror". So which desktop 
are you running? KDE or Unity or even something else?

> >    ps ax | grep gedit
> 
> tried an experiment--
> 
> if from konq, I get:
> .... /usr/bin/gedit   plus   what file name was opened-
> opens with "untitled document 1"
> 
> if from Nautilus, I get:
> ....   what file name was opened, not preceded by
> /usr/bin/gedit  - so there is a difference in how it's called-
> opens without "untitled document 1"

I'm not sure what you mean here - is it something like this?

... /usr/bin/gedit somefile.txt "untitled document 1"

If that's the case, there could be something wrong with the file type 
options for opening a file with gedit. I just tried the behaviour of a 
freshly installed gedit run from konqueror, and there was no extra file 
"untitled document 1". So please check the file type options:

>From konqueror right click the icon of a text file and select 
"Properties" and in the new window select "File Type Options". In the 
lower right selection area select gedit and on the right click the 
"Edit…" button. Select the "Application" tab and make sure that the 
entry in the line "Command" is "gedit %U". Click "OK" (several times) 
and check if it still opens the extra file "untitled document 1".


Nils




More information about the ubuntu-users mailing list