Big Disk Performance Difference Between 13.04/14.10 and 14.04

Tom H tomh0665 at gmail.com
Fri Jan 16 11:55:50 UTC 2015


On Fri, Jan 9, 2015 at 3:00 PM, Paul Brown <paul90brown at gmail.com> wrote:
>
> The fix ended up being BIOS power profile settings. It was set to
> Performance Per Watt (DAPC) and needed to be set to "Performance".

Thanks for letting us know.


> On Thu, Jan 8, 2015 at 11:04 PM, Paul Brown <paul90brown at gmail.com> wrote:
>>
>> When I look at info about the raid volume it says "Sector Size: 512". That
>> means I'm not affected by 4k sector problems?
>>
>> I learned a bit more about the machines. They're not exactly the same. The
>> two poorly performing machines have different raid controller chipset
>> revisions and motherboard chipset revisions. And they still perform poorly
>> even when they're on 13.04 (same version as the good machine).
>>
>> Oddly enough, the two poorly performing machines have great read speed
>> when they're on Ubuntu 14.10, but the write speed is still not so good.
>>
>> On Thu, Jan 8, 2015 at 9:33 PM, blind Pete <0123peter at gmail.com> wrote:
>>>
>>> Paul Brown wrote:
>>>
>>> > I have three of the exact same dell r620 server (with a PERC H710 Mini
>>> > raid controller) and I'm seeing disk performance differences across
>>> > Ubuntu
>>> > 13.04, 14.04, and 14.10.
>>> >
>>> > Read speed is 100% *better *on 13.04 and 14.10 - compared to 14.04.
>>> > Write speed is 50% *worse *on both 14.10 and 14.04 - compared to 13.04
>>> >
>>> > More detail about the benchmarks is here:
>>> >
>>> > http://www.paulsprogrammingnotes.com/2015/01/slow-disk-performance-on-ubuntu-1304-vs.html
>>> >
>>> > Does anyone know what is likely to cause this issue?
>>>
>>> Wild stab in the dark:
>>>
>>> 4k sector (mis) alignment?



More information about the ubuntu-users mailing list